Skip to content

← Actionable
Medium, CVSS 5.3amended

Bypass of CSRF protection in the presence of predictable userInfo

CVE-2023-27495GHSA-qrgf-9gpc-vrxw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/csrf-protection 6.3.0, 4.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N
EPSS
  • CVE-2023-27495: 0.33% estimated exploitation activity in the next 30 days; percentile 26.36 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description The CSRF protection enforced by the @fastify/csrf-protection library in combination with @fastify/cookie can be bypassed from network and same-site attackers under certain conditions. @fastify/csrf-protection supports an optional userInfo parameter that binds the CSRF token to the user. This parameter has been introduced to prevent cookie-tossing attacks as a fix for CVE-2021-29624. Whenever userInfo parameter is missing, or its value can be predicted for the target user account, network and same-site attackers can 1. fixate a csrf cookie in the victim's browser, and 2. forge CSRF tokens that are valid for the victim's session. This allows attackers to bypass the CSRF protection mechanism. As a fix, @fastify/csrf-protection starting from version 6.3.0 (and v4.1.0) includes a server-defined secret hmacKey that cryptographically binds the CSRF token to the value of the csrf cookie and the userInfo parameter, making tokens non-spoofable by attackers. This protection is…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qrgf-9gpc-vrxw

  2. Revision 1 · created ·

    Published from osv record GHSA-qrgf-9gpc-vrxw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-27495

Advisory: Bypass of CSRF protection in the presence of predictable userInfo
IDs: CVE-2023-27495, GHSA-qrgf-9gpc-vrxw
Record: https://patchnext.com/advisories/cve-2023-27495 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fastify/csrf-protection 6.3.0, 4.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fastify/csrf-protection: affected < 4.1.0; >= 5.0.0, < 6.3.0; fixed in 6.3.0, 4.1.0

## Suggested inspection (read-only)
- `npm ls @fastify/csrf-protection --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fastify/csrf-protection.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qrgf-9gpc-vrxw (OSV record GHSA-qrgf-9gpc-vrxw lists affected ranges: npm @fastify/csrf-protection >=0 =5.0.0 <6.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-qrgf-9gpc-vrxw (GitHub-reviewed advisory GHSA-qrgf-9gpc-vrxw lists affected ranges: npm @fastify/csrf-protection >=0 =5.0.0 <6.3.0)

Commands are suggestions: review each one before running it.

Loading voting…