Skip to content

← Actionable
Medium, CVSS 6.0amended

Streamlit publishes previously-patched Cross-site Scripting vulnerability

CVE-2023-27494GHSA-9c6g-qpgj-rvxw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (streamlit 0.81.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI streamlit

    Affected
    >= 0.63.0, < 0.81.0
    Fixed in
    0.81.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2023-27494: 0.41% estimated exploitation activity in the next 30 days; percentile 35.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Synopsis: Streamlit open source publicizes a prior security fix implemented in 2021. The vulnerability affected Streamlit versions between 0.63.0 and 0.80.0 (inclusive) and was patched on April 21, 2021. If you are using Streamlit with version before 0.63.0 or after 0.80.0, no action is required. 1. Impacted Products Streamilt Open Source versions between 0.63.0 and 0.80.0. 2. Introduction On April 21, 2021, Streamlit merged a patch that fixed a cross-site scripting (XSS) vulnerability in the Streamlit open source library, without an associated public advisory. The vulnerability affected Streamlit versions between 0.63.0 and 0.80.0 (inclusive), which are no longer supported. We recommend using the latest version of our library, but so long as you are not using an affected Streamlit version, no action is required. 3. Cross Site Scripting Vulnerability 3.1 Description On April 20, 2021, Streamlit was informed via our support forum about a XSS vulnerability in the open source library.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9c6g-qpgj-rvxw

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9c6g-qpgj-rvxw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-27494

Advisory: Streamlit publishes previously-patched Cross-site Scripting vulnerability
IDs: CVE-2023-27494, GHSA-9c6g-qpgj-rvxw
Record: https://patchnext.com/advisories/cve-2023-27494 (revision 3, source checked 26 Oct 2026, 13:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: streamlit 0.81.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI streamlit: affected >= 0.63.0, < 0.81.0; fixed in 0.81.0

## Suggested inspection (read-only)
- `python -m pip show streamlit`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on streamlit.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9c6g-qpgj-rvxw (OSV record GHSA-9c6g-qpgj-rvxw lists affected ranges: PyPI streamlit >=0.63.0 <0.81.0 (fixed))
- Verified: https://github.com/advisories/GHSA-9c6g-qpgj-rvxw (GitHub-reviewed advisory GHSA-9c6g-qpgj-rvxw lists affected ranges: PyPI streamlit >=0.63.0 <0.81.0)

Commands are suggestions: review each one before running it.

Loading voting…