Missing proper state, nonce and PKCE checks for OAuth authentication
CVE-2023-27490GHSA-7r7x-4c4q-c4qf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (next-auth 4.20.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm next-auth
- Affected
- < 4.20.1
- Fixed in
- 4.20.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7r7x-4c4q-c4qf lists affected ranges: npm next-auth >=0 <4.20.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7r7x-4c4q-c4qf lists affected ranges: npm next-auth >=0 <4.20.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
- EPSS
- CVE-2023-27490: 0.54% estimated exploitation activity in the next 30 days; percentile 45.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact next-auth applications using OAuth provider versions before v4.20.1 are affected. A bad actor who can spy on the victim's network or able to social engineer the victim to click a manipulated login link could intercept and tamper with the authorization URL to log in as the victim, bypassing the CSRF protection. As an example, an attack can happen in the following scenario. TL;DR: The attacker steals the victim's authenticated callback by intercepting and tampering with the authorization URL created by next-auth. 1. The victim attempts to log in to the next-auth site. For example https://next-auth-example.vercel.app/ 2. next-auth sets the checks cookies according to how the OAuth provider is configured. In this case, state and pkce are set by default for the Google Provider. <img width="1971" alt="Screen Shot 2023-03-03 at 09 54 26" src="https://user-images.githubusercontent.com/31528554/222619750-a2062bb8-99eb-4985-a75c-d75acd3da67e.png" 3. The attacker intercepts the returned…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7r7x-4c4q-c4qf
- Revision 1 · created ·
Published from osv record GHSA-7r7x-4c4q-c4qf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-27490 Advisory: Missing proper state, nonce and PKCE checks for OAuth authentication IDs: CVE-2023-27490, GHSA-7r7x-4c4q-c4qf Record: https://patchnext.com/advisories/cve-2023-27490 (revision 2, source checked 26 Oct 2026, 12:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: next-auth 4.20.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm next-auth: affected < 4.20.1; fixed in 4.20.1 ## Suggested inspection (read-only) - `npm ls next-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on next-auth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7r7x-4c4q-c4qf (OSV record GHSA-7r7x-4c4q-c4qf lists affected ranges: npm next-auth >=0 <4.20.1 (fixed)) - Verified: https://github.com/advisories/GHSA-7r7x-4c4q-c4qf (GitHub-reviewed advisory GHSA-7r7x-4c4q-c4qf lists affected ranges: npm next-auth >=0 <4.20.1) Commands are suggestions: review each one before running it.
Loading voting…