Skip to content

← Actionable
Medium, CVSS 6.5amended

Directus vulnerable to extraction of password hashes through export querying

CVE-2023-27481GHSA-m5q3-8wgf-x8xf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (directus 9.16.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm directus

    Affected
    < 9.16.0
    Fixed in
    9.16.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2023-27481: 0.60% estimated exploitation activity in the next 30 days; percentile 48.97 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users with read access to the password field in directususers can extract the argon2 password hashes by brute forcing the export functionality combined with a startswith filter. This allows the user to enumerate the password hashes. Patches The problem has been patched by preventing any hashed/concealed field to be filtered against with the startswith or other string operator. Workarounds Ensuring that no user has read access to the password field in directususers is sufficient to prevent this vulnerability. For more information If you have any questions or comments about this advisory: Open a Discussion in directus/directus Email us at security@directus.io

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m5q3-8wgf-x8xf

  2. Revision 1 · created ·

    Published from osv record GHSA-m5q3-8wgf-x8xf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-27481

Advisory: Directus vulnerable to extraction of password hashes through export querying
IDs: CVE-2023-27481, GHSA-m5q3-8wgf-x8xf
Record: https://patchnext.com/advisories/cve-2023-27481 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: directus 9.16.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm directus: affected < 9.16.0; fixed in 9.16.0

## Suggested inspection (read-only)
- `npm ls directus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on directus.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m5q3-8wgf-x8xf (OSV record GHSA-m5q3-8wgf-x8xf lists affected ranges: npm directus >=0 <9.16.0 (fixed))
- Verified: https://github.com/advisories/GHSA-m5q3-8wgf-x8xf (GitHub-reviewed advisory GHSA-m5q3-8wgf-x8xf lists affected ranges: npm directus >=0 <9.16.0)

Commands are suggestions: review each one before running it.

Loading voting…