Vega has Cross-site Scripting vulnerability in lassoAppend function
CVE-2023-26487GHSA-w5m3-xh75-mp55
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (vega 5.23.0; vega-functions 5.13.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm vega
- Affected
- < 5.23.0
- Fixed in
- 5.23.0
npm vega-functions
- Affected
- < 5.13.1
- Fixed in
- 5.13.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-w5m3-xh75-mp55 lists affected ranges: npm vega >=0 =0 <5.13.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w5m3-xh75-mp55 lists affected ranges: npm vega >=0 =0 <5.13.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-26487: 0.81% estimated exploitation activity in the next 30 days; percentile 56.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Vega's lassoAppend function: lassoAppend accepts 3 arguments and internally invokes push function on the 1st argument specifying array consisting of 2nd and 3rd arguments as push call argument. The type of the 1st argument is supposed to be an array, but it's not enforced. This makes it possible to specify any object with a push function as the 1st argument, push function can be set to any function that can be access via event.view (no all such functions can be exploited due to invalid context or signature, but some can, e.g. console.log). Details The issue is that lassoAppend doesn't enforce proper types of its arguments: PoC Use the following Vega snippet (depends on browser's non-built-in event.view.setImmediate function, feel free to replace with event.view.console.log or alike and observe the result in the browser's console) Impact This issue opens various XSS vectors, but exact impact and severity depends on the environment (e.g. Core JS setImmediate polyfill basically…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-w5m3-xh75-mp55
- Revision 1 · created ·
Published from osv record GHSA-w5m3-xh75-mp55
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-26487 Advisory: Vega has Cross-site Scripting vulnerability in `lassoAppend` function IDs: CVE-2023-26487, GHSA-w5m3-xh75-mp55 Record: https://patchnext.com/advisories/cve-2023-26487 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: vega 5.23.0; vega-functions 5.13.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm vega: affected < 5.23.0; fixed in 5.23.0 - npm vega-functions: affected < 5.13.1; fixed in 5.13.1 ## Suggested inspection (read-only) - `npm ls vega --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls vega-functions --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on vega, vega-functions. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-w5m3-xh75-mp55 (OSV record GHSA-w5m3-xh75-mp55 lists affected ranges: npm vega >=0 =0 <5.13.1 (fixed)) - Verified: https://github.com/advisories/GHSA-w5m3-xh75-mp55 (GitHub-reviewed advisory GHSA-w5m3-xh75-mp55 lists affected ranges: npm vega >=0 =0 <5.13.1) Commands are suggestions: review each one before running it.
Loading voting…