Skip to content

← Actionable
Medium, CVSS 6.1amended

Vega Expression Language scale expression function Cross Site Scripting

CVE-2023-26486GHSA-4vq7-882g-wcg4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (vega 5.23.0; vega-functions 5.13.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2023-26486: 0.78% estimated exploitation activity in the next 30 days; percentile 55.81 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Vega scale expression function has the ability to call arbitrary functions with a single controlled argument. This can be exploited to escape the Vega expression sandbox in order to execute arbitrary JavaScript. Details The scale expression function passes a user supplied argument group to getScale, which is then used as if it were an internal context. The context.scales[name].value is accessed from group and called as a function back in scale. PoC The following Vega definition can be used to demonstrate this issue executing the JavaScript code alert(1); This can be viewed in the Vega online IDE at…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4vq7-882g-wcg4

  2. Revision 1 · created ·

    Published from osv record GHSA-4vq7-882g-wcg4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-26486

Advisory: Vega Expression Language `scale` expression function Cross Site Scripting
IDs: CVE-2023-26486, GHSA-4vq7-882g-wcg4
Record: https://patchnext.com/advisories/cve-2023-26486 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: vega 5.23.0; vega-functions 5.13.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm vega: affected < 5.23.0; fixed in 5.23.0
- npm vega-functions: affected < 5.13.1; fixed in 5.13.1

## Suggested inspection (read-only)
- `npm ls vega --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls vega-functions --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on vega, vega-functions.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4vq7-882g-wcg4 (OSV record GHSA-4vq7-882g-wcg4 lists affected ranges: npm vega-functions >=0 =0 <5.23.0 (fixed))
- Verified: https://github.com/advisories/GHSA-4vq7-882g-wcg4 (GitHub-reviewed advisory GHSA-4vq7-882g-wcg4 lists affected ranges: npm vega-functions >=0 =0 <5.23.0)

Commands are suggestions: review each one before running it.

Loading voting…