Skip to content

← Actionable
Medium, CVSS 6.5

xwiki vulnerable to Improper Handling of Exceptional Conditions

CVE-2023-26479GHSA-52vf-hvv3-98h7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-rendering-parser 14.9-rc-1, 14.4.6, 13.10.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-52vf-hvv3-98h7 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-rendering-parser >=6.0 =14.0 =14.5 <14.9-rc-1

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-26479: 1.08% estimated exploitation activity in the next 30 days; percentile 65.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users with write rights can insert well-formed content that is not handled well by the parser. For instance, with xwiki/2.1, inserting a deeply nested group blocks (((( ((( ((( ((( .... ))) ))) ))) ))) (see the generator below to produce a large payload) can lead to the parser throwing a StackOverflowError. As a consequence, some pages becomes unusable, including: - the user index (if the page containing the faulty content is a user page) - the page index Note that on the page, the normal UI is completely missing and it is not possible to open the editor directly to revert the change as the stack overflow is already triggered while getting the title of the document. This means that it is quite difficult to remove this content once inserted. Patches This has been patched on XWiki 13.10.10, 14.4.6, and 14.9-rc-1. Workarounds A temporary solution to avoid Stack Overflow errors is to increase the memory allocated to the stack by using the -Xss JVM parameter (e.g., -Xss32m). This…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-52vf-hvv3-98h7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-26479

Advisory: xwiki vulnerable to Improper Handling of Exceptional Conditions
IDs: CVE-2023-26479, GHSA-52vf-hvv3-98h7
Record: https://patchnext.com/advisories/cve-2023-26479 (revision 1, source checked 26 Oct 2026, 16:10 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-rendering-parser 14.9-rc-1, 14.4.6, 13.10.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.xwiki.platform:xwiki-platform-rendering-parser: affected >= 6.0, < 13.10.10; >= 14.0, < 14.4.6; >= 14.5, < 14.9-rc-1; fixed in 14.4.6, 14.9-rc-1, 13.10.10

## Suggested inspection (read-only)
- Maven org.xwiki.platform:xwiki-platform-rendering-parser: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.xwiki.platform:xwiki-platform-rendering-parser.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-52vf-hvv3-98h7 (GitHub-reviewed advisory GHSA-52vf-hvv3-98h7 lists affected ranges: Maven org.xwiki.platform:xwiki-platform-rendering-parser >=6.0 =14.0 =14.5 <14.9-rc-1)

Commands are suggestions: review each one before running it.

Loading voting…