XWiki Platform vulnerable to privilege escalation via properties with wiki syntax that are executed with wrong author
CVE-2023-26474GHSA-3738-p9x3-mv9r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.xwiki.platform:xwiki-platform-oldcore 14.10, 14.4.7, 13.10.11; org.xwiki.platform:xwiki-platform-legacy-oldcore 14.10, 14.4.7, 13.10.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.xwiki.platform:xwiki-platform-oldcore
- Affected
- >= 13.10, < 13.10.11>= 14.0, < 14.4.7>= 14.5, < 14.10
- Fixed in
- 14.10, 14.4.7, 13.10.11
Maven org.xwiki.platform:xwiki-platform-legacy-oldcore
- Affected
- >= 13.10, < 13.10.11>= 14.0, < 14.4.7>= 14.5, < 14.10
- Fixed in
- 14.10, 14.4.7, 13.10.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3738-p9x3-mv9r lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=13.10 =14.0 =14.5 =13.10 =14.0 =14.5 <14.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-26474: 0.79% estimated exploitation activity in the next 30 days; percentile 56.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact It's possible to use the right of an existing document content author to execute a text area property. To reproduce: As an admin with programming rights, create a new user without script or programming right. Login with the freshly created user. Insert the following text in source mode in the about section: Click "Save & View" Patches This has been patched in XWiki 14.10, 14.4.7, and 13.10.11. Workarounds No known workaround. References https://jira.xwiki.org/browse/XWIKI-20373 For more information If you have any questions or comments about this advisory: Open an issue in Jira Email us at Security ML
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-3738-p9x3-mv9r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-26474 Advisory: XWiki Platform vulnerable to privilege escalation via properties with wiki syntax that are executed with wrong author IDs: CVE-2023-26474, GHSA-3738-p9x3-mv9r Record: https://patchnext.com/advisories/cve-2023-26474 (revision 1, source checked 26 Oct 2026, 16:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.xwiki.platform:xwiki-platform-oldcore 14.10, 14.4.7, 13.10.11; org.xwiki.platform:xwiki-platform-legacy-oldcore 14.10, 14.4.7, 13.10.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.xwiki.platform:xwiki-platform-oldcore: affected >= 13.10, < 13.10.11; >= 14.0, < 14.4.7; >= 14.5, < 14.10; fixed in 14.10, 14.4.7, 13.10.11 - Maven org.xwiki.platform:xwiki-platform-legacy-oldcore: affected >= 13.10, < 13.10.11; >= 14.0, < 14.4.7; >= 14.5, < 14.10; fixed in 14.10, 14.4.7, 13.10.11 ## Suggested inspection (read-only) - Maven org.xwiki.platform:xwiki-platform-oldcore: check the installed version with your package manager. - Maven org.xwiki.platform:xwiki-platform-legacy-oldcore: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.xwiki.platform:xwiki-platform-oldcore, org.xwiki.platform:xwiki-platform-legacy-oldcore. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-3738-p9x3-mv9r (GitHub-reviewed advisory GHSA-3738-p9x3-mv9r lists affected ranges: Maven org.xwiki.platform:xwiki-platform-oldcore >=13.10 =14.0 =14.5 =13.10 =14.0 =14.5 <14.10) Commands are suggestions: review each one before running it.
Loading voting…