Apache Log4j 1.x (EOL) allows Denial of Service (DoS)
CVE-2023-26464GHSA-vp98-w2p3-mv35
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.logging.log4j:log4j-core 2.0; log4j:log4j 2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.logging.log4j:log4j-core
- Affected
- >= 1.0.4, < 2.0
- Fixed in
- 2.0
Maven log4j:log4j
- Affected
- >= 1.0.4, < 2.0
- Fixed in
- 2.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vp98-w2p3-mv35 lists affected ranges: Maven org.apache.logging.log4j:log4j-core >=1.0.4 =1.0.4 <2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-26464: 1.91% estimated exploitation activity in the next 30 days; percentile 79.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
UNSUPPORTED WHEN ASSIGNED When using the Chainsaw or SocketAppender components with Log4j 1.x on JRE less than 1.7, an attacker that manages to cause a logging entry involving a specially-crafted (ie deeply nested) hashmap or hashtable (depending on which logging component is in use) to be processed could exhaust the available memory in the virtual machine and achieve Denial of Service when the object is deserialized. This issue affects Apache Log4j before 2. Affected users are recommended to update to Log4j 2.x. NOTE: This vulnerability only affects products that are no longer supported by the maintainer.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vp98-w2p3-mv35
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-26464 Advisory: Apache Log4j 1.x (EOL) allows Denial of Service (DoS) IDs: CVE-2023-26464, GHSA-vp98-w2p3-mv35 Record: https://patchnext.com/advisories/cve-2023-26464 (revision 1, source checked 26 Oct 2026, 16:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.logging.log4j:log4j-core 2.0; log4j:log4j 2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.logging.log4j:log4j-core: affected >= 1.0.4, < 2.0; fixed in 2.0 - Maven log4j:log4j: affected >= 1.0.4, < 2.0; fixed in 2.0 ## Suggested inspection (read-only) - Maven org.apache.logging.log4j:log4j-core: check the installed version with your package manager. - Maven log4j:log4j: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.logging.log4j:log4j-core, log4j:log4j. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vp98-w2p3-mv35 (GitHub-reviewed advisory GHSA-vp98-w2p3-mv35 lists affected ranges: Maven org.apache.logging.log4j:log4j-core >=1.0.4 =1.0.4 <2.0) Commands are suggestions: review each one before running it.
Loading voting…