markdown-it-py Denial of Service vulnerability in the command line interface
CVE-2023-26302GHSA-jrwr-5x3p-hvc3
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (markdown-it-py 2.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI markdown-it-py
- Affected
- < 2.2.0
- Fixed in
- 2.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jrwr-5x3p-hvc3 lists affected ranges: PyPI markdown-it-py >=0 <2.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jrwr-5x3p-hvc3 lists affected ranges: PyPI markdown-it-py >=0 <2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-26302: 0.23% estimated exploitation activity in the next 30 days; percentile 13.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Denial of service could be caused to the command line interface of markdown-it-py, before v2.2.0, if an attacker was allowed to use invalid UTF-8 characters as input.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-jrwr-5x3p-hvc3
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-jrwr-5x3p-hvc3
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-26302 Advisory: markdown-it-py Denial of Service vulnerability in the command line interface IDs: CVE-2023-26302, GHSA-jrwr-5x3p-hvc3 Record: https://patchnext.com/advisories/cve-2023-26302 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: markdown-it-py 2.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI markdown-it-py: affected < 2.2.0; fixed in 2.2.0 ## Suggested inspection (read-only) - `python -m pip show markdown-it-py`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on markdown-it-py. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jrwr-5x3p-hvc3 (OSV record GHSA-jrwr-5x3p-hvc3 lists affected ranges: PyPI markdown-it-py >=0 <2.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jrwr-5x3p-hvc3 (GitHub-reviewed advisory GHSA-jrwr-5x3p-hvc3 lists affected ranges: PyPI markdown-it-py >=0 <2.2.0) Commands are suggestions: review each one before running it.
Loading voting…