Follow Redirects improperly handles URLs in the url.parse() function
CVE-2023-26159GHSA-jchw-25xp-jwwc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (follow-redirects 1.15.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm follow-redirects
- Affected
- < 1.15.4
- Fixed in
- 1.15.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jchw-25xp-jwwc lists affected ranges: npm follow-redirects >=0 <1.15.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jchw-25xp-jwwc lists affected ranges: npm follow-redirects >=0 <1.15.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-26159: 0.80% estimated exploitation activity in the next 30 days; percentile 56.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package follow-redirects before 1.15.4 are vulnerable to Improper Input Validation due to the improper handling of URLs by the url.parse() function. When new URL() throws an error, it can be manipulated to misinterpret the hostname. An attacker could exploit this weakness to redirect traffic to a malicious site, potentially leading to information disclosure, phishing attacks, or other security breaches.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jchw-25xp-jwwc
- Revision 1 · created ·
Published from osv record GHSA-jchw-25xp-jwwc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-26159 Advisory: Follow Redirects improperly handles URLs in the url.parse() function IDs: CVE-2023-26159, GHSA-jchw-25xp-jwwc Record: https://patchnext.com/advisories/cve-2023-26159 (revision 2, source checked 26 Oct 2026, 12:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: follow-redirects 1.15.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm follow-redirects: affected < 1.15.4; fixed in 1.15.4 ## Suggested inspection (read-only) - `npm ls follow-redirects --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on follow-redirects. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jchw-25xp-jwwc (OSV record GHSA-jchw-25xp-jwwc lists affected ranges: npm follow-redirects >=0 <1.15.4 (fixed)) - Verified: https://github.com/advisories/GHSA-jchw-25xp-jwwc (GitHub-reviewed advisory GHSA-jchw-25xp-jwwc lists affected ranges: npm follow-redirects >=0 <1.15.4) Commands are suggestions: review each one before running it.
Loading voting…