chromedriver Command Injection vulnerability
CVE-2023-26156GHSA-hm92-vgmw-qfmx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (chromedriver 119.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm chromedriver
- Affected
- < 119.0.1
- Fixed in
- 119.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hm92-vgmw-qfmx lists affected ranges: npm chromedriver >=0 <119.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hm92-vgmw-qfmx lists affected ranges: npm chromedriver >=0 <119.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.6 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- CVE-2023-26156: 2.23% estimated exploitation activity in the next 30 days; percentile 82.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package chromedriver before 119.0.1 are vulnerable to Command Injection when setting the chromedriver.path to an arbitrary system binary. This could lead to unauthorized access and potentially malicious actions on the host system. Note: An attacker must have access to the system running the vulnerable chromedriver library to exploit it. The success of exploitation also depends on the permissions and privileges of the process running chromedriver.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hm92-vgmw-qfmx
- Revision 1 · created ·
Published from osv record GHSA-hm92-vgmw-qfmx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-26156 Advisory: chromedriver Command Injection vulnerability IDs: CVE-2023-26156, GHSA-hm92-vgmw-qfmx Record: https://patchnext.com/advisories/cve-2023-26156 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: chromedriver 119.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm chromedriver: affected < 119.0.1; fixed in 119.0.1 ## Suggested inspection (read-only) - `npm ls chromedriver --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on chromedriver. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hm92-vgmw-qfmx (OSV record GHSA-hm92-vgmw-qfmx lists affected ranges: npm chromedriver >=0 <119.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-hm92-vgmw-qfmx (GitHub-reviewed advisory GHSA-hm92-vgmw-qfmx lists affected ranges: npm chromedriver >=0 <119.0.1) Commands are suggestions: review each one before running it.
Loading voting…