pubnub Insufficient Entropy vulnerability
CVE-2023-26154GHSA-5844-q3fc-56rh
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pubnub
- Affected
- < 7.4.0
- Fixed in
- 7.4.0
Maven com.pubnub:pubnub
- Affected
- <= 4.6.5
- Fixed in
- no fixed version recorded
Maven com.pubnub:pubnub-kotlin
- Affected
- < 7.7.0
- Fixed in
- 7.7.0
Packagist pubnub/pubnub
- Affected
- < 6.1.0
- Fixed in
- 6.1.0
Go github.com/pubnub/go/v6
- Affected
- < 6.1.1-0.20231016150651-428517fef5b9
- Fixed in
- 6.1.1-0.20231016150651-428517fef5b9
Go github.com/pubnub/go/v7
- Affected
- < 7.2.0
- Fixed in
- 7.2.0
RubyGems pubnub
- Affected
- < 5.3.0
- Fixed in
- 5.3.0
Go github.com/pubnub/go/v5
- Affected
- < 5.0.4-0.20231016150651-428517fef5b9
- Fixed in
- 5.0.4-0.20231016150651-428517fef5b9
crates.io pubnub
- Affected
- < 0.4.0
- Fixed in
- 0.4.0
NuGet pubnub
- Affected
- < 6.19.0
- Fixed in
- 6.19.0
PyPI pubnub
- Affected
- < 7.3.0
- Fixed in
- 7.3.0
Go github.com/pubnub/go
- Affected
- < 0.0.0-20231016150651-428517fef5b9
- Fixed in
- 0.0.0-20231016150651-428517fef5b9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record PYSEC-2026-1807 lists affected ranges: PyPI pubnub >=0 <7.3.0 (fixed)
VerifiedObserved Structured OSV record; not marked as GitHub-reviewed.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5844-q3fc-56rh lists affected ranges: npm pubnub >=0 =0 =0 =0 =0 =0 =0 =0 =0 =0 =0 <6.1.1-0.20231016150651-428517fef5b9; Go…
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2023-26154: 0.96% estimated exploitation activity in the next 30 days; percentile 61.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package pubnub before 7.4.0; all versions of the package com.pubnub:pubnub; versions of the package pubnub before 6.19.0; all versions of the package github.com/pubnub/go; versions of the package github.com/pubnub/go/v7 before 7.2.0; versions of the package pubnub before 7.3.0; versions of the package pubnub/pubnub before 6.1.0; versions of the package pubnub before 5.3.0; versions of the package pubnub before 0.4.0; versions of the package pubnub/c-core before 4.5.0; versions of the package com.pubnub:pubnub-kotlin before 7.7.0; versions of the package pubnub/swift before 6.2.0; versions of the package pubnub before 5.2.0; versions of the package pubnub before 4.3.0 are vulnerable to Insufficient Entropy via the getKey function, due to inefficient implementation of the AES-256-CBC cryptographic algorithm. The provided encrypt function is less secure when hex encoding and trimming are applied, leaving half of the bits in the key always the same for every encoded…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5844-q3fc-56rh
- Revision 1 · created ·
Published from osv record PYSEC-2026-1807
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-26154 Advisory: pubnub Insufficient Entropy vulnerability IDs: CVE-2023-26154, GHSA-5844-q3fc-56rh Record: https://patchnext.com/advisories/cve-2023-26154 (revision 2, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: pubnub 7.4.0; com.pubnub:pubnub-kotlin 7.7.0; pubnub/pubnub 6.1.0; github.com/pubnub/go/v6 6.1.1-0.20231016150651-428517fef5b9; github.com/pubnub/go/v7 7.2.0; pubnub 5.3.0; github.com/pubnub/go/v5 5.0.4-0.20231016150651-428517fef5b9; pubnub 0.4.0; pubnub 6.19.0; pubnub 7.3.0; github.com/pubnub/go 0.0.0-20231016150651-428517fef5b9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pubnub: affected < 7.4.0; fixed in 7.4.0 - Maven com.pubnub:pubnub: affected <= 4.6.5 - Maven com.pubnub:pubnub-kotlin: affected < 7.7.0; fixed in 7.7.0 - Packagist pubnub/pubnub: affected < 6.1.0; fixed in 6.1.0 - Go github.com/pubnub/go/v6: affected < 6.1.1-0.20231016150651-428517fef5b9; fixed in 6.1.1-0.20231016150651-428517fef5b9 - Go github.com/pubnub/go/v7: affected < 7.2.0; fixed in 7.2.0 - RubyGems pubnub: affected < 5.3.0; fixed in 5.3.0 - Go github.com/pubnub/go/v5: affected < 5.0.4-0.20231016150651-428517fef5b9; fixed in 5.0.4-0.20231016150651-428517fef5b9 - crates.io pubnub: affected < 0.4.0; fixed in 0.4.0 - NuGet pubnub: affected < 6.19.0; fixed in 6.19.0 - PyPI pubnub: affected < 7.3.0; fixed in 7.3.0 - Go github.com/pubnub/go: affected < 0.0.0-20231016150651-428517fef5b9; fixed in 0.0.0-20231016150651-428517fef5b9 ## Suggested inspection (read-only) - `npm ls pubnub --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - Maven com.pubnub:pubnub: check the installed version with your package manager. - Maven com.pubnub:pubnub-kotlin: check the installed version with your package manager. - Packagist pubnub/pubnub: check the installed version with your package manager. - Go github.com/pubnub/go/v6: check the installed version with your package manager. - Go github.com/pubnub/go/v7: check the installed version with your package manager. - RubyGems pubnub: check the installed version with your package manager. - Go github.com/pubnub/go/v5: check the installed version with your package manager. - crates.io pubnub: check the installed version with your package manager. - NuGet pubnub: check the installed version with your package manager. - `python -m pip show pubnub`: prints the installed version. Run with the environment that serves production active. - Go github.com/pubnub/go: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pubnub, com.pubnub:pubnub, com.pubnub:pubnub-kotlin, pubnub/pubnub, github.com/pubnub/go/v6, github.com/pubnub/go/v7, github.com/pubnub/go/v5, github.com/pubnub/go. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/PYSEC-2026-1807 (OSV record PYSEC-2026-1807 lists affected ranges: PyPI pubnub >=0 <7.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5844-q3fc-56rh (GitHub-reviewed advisory GHSA-5844-q3fc-56rh lists affected ranges: npm pubnub >=0 =0 =0 =0 =0 =0 =0 =0 =0 =0 =0 <6.1.1-0.20231016150651-428517fef5b9; Go…) Commands are suggestions: review each one before running it.
Loading voting…