Skip to content

← Actionable
Low, CVSS 3.7amended

Saleor Unauthenticated Information Disclosure Vulnerability via Python Exceptions

CVE-2023-26052GHSA-3hvj-3cg9-v242

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (saleor 3.11.12, 3.10.14, 3.9.27, 3.8.30, 3.7.59, 3.1.48), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI saleor

    Affected
    >= 2.0.0, < 3.1.48>= 3.11.0, < 3.11.12>= 3.10.0, < 3.10.14>= 3.9.0, < 3.9.27>= 3.8.0, < 3.8.30>= 3.7.0, < 3.7.59
    Fixed in
    3.8.30, 3.10.14, 3.11.12, 3.9.27, 3.7.59, 3.1.48

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2023-26052: 0.76% estimated exploitation activity in the next 30 days; percentile 55.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Some internal Python exceptions are not handled properly and thus are returned in API as error messages. Some messages might contain sensitive information like infrastructure details in unauthenticated requests. Affected versions: Saleor ≥ 2.0.0 Workarounds None For more information If you have any questions or comments about this advisory: Open a discussion at https://github.com/saleor/saleor/discussions Email us at hello@saleor.io

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3hvj-3cg9-v242

  2. Revision 1 · created ·

    Published from osv record GHSA-3hvj-3cg9-v242

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-26052

Advisory: Saleor Unauthenticated Information Disclosure Vulnerability via Python Exceptions
IDs: CVE-2023-26052, GHSA-3hvj-3cg9-v242
Record: https://patchnext.com/advisories/cve-2023-26052 (revision 2, source checked 26 Oct 2026, 13:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: saleor 3.11.12, 3.10.14, 3.9.27, 3.8.30, 3.7.59, 3.1.48. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI saleor: affected >= 2.0.0, < 3.1.48; >= 3.11.0, < 3.11.12; >= 3.10.0, < 3.10.14; >= 3.9.0, < 3.9.27; >= 3.8.0, < 3.8.30; >= 3.7.0, < 3.7.59; fixed in 3.8.30, 3.10.14, 3.11.12, 3.9.27, 3.7.59, 3.1.48

## Suggested inspection (read-only)
- `python -m pip show saleor`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on saleor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3hvj-3cg9-v242 (OSV record GHSA-3hvj-3cg9-v242 lists affected ranges: PyPI saleor >=2.0.0 =3.11.0 =3.10.0 =3.9.0 =3.8.0 =3.7.0 <3.7.59 (fixed))
- Verified: https://github.com/advisories/GHSA-3hvj-3cg9-v242 (GitHub-reviewed advisory GHSA-3hvj-3cg9-v242 lists affected ranges: PyPI saleor >=2.0.0 =3.11.0 =3.10.0 =3.9.0 =3.8.0 =3.7.0 <3.7.59)

Commands are suggestions: review each one before running it.

Loading voting…