teler-waf subject to Bypass of Common Web Attack Threat Rule with HTML Entities Payload
CVE-2023-26046GHSA-9f95-hhg4-pg4f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kitabisa/teler-waf 0.1.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/kitabisa/teler-waf
- Affected
- < 0.1.1
- Fixed in
- 0.1.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9f95-hhg4-pg4f lists affected ranges: Go github.com/kitabisa/teler-waf >=0 <0.1.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-26046: 0.54% estimated exploitation activity in the next 30 days; percentile 45.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description teler-waf is a Go HTTP middleware that provides teler IDS functionality to protect against web-based attacks. Versions prior to v0.1.1 are vulnerable to bypassing common web attack rules when a specific HTML entities payload is used. This vulnerability allows an attacker to execute arbitrary JavaScript code on the victim's browser and compromise the security of the web application. The vulnerability exists due to teler-waf failure to properly sanitize and filter HTML entities in user input. Impact An attacker can exploit this vulnerability to bypass common web attack threat rules in teler-waf and launch cross-site scripting (XSS) attacks. The attacker can execute arbitrary JavaScript code on the victim's browser and steal sensitive information, such as login credentials and session tokens, or take control of the victim's browser and perform malicious actions. Patches Version v0.1.1 includes a patch for this vulnerability. Workarounds We advised updating their…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9f95-hhg4-pg4f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-26046 Advisory: teler-waf subject to Bypass of Common Web Attack Threat Rule with HTML Entities Payload IDs: CVE-2023-26046, GHSA-9f95-hhg4-pg4f Record: https://patchnext.com/advisories/cve-2023-26046 (revision 1, source checked 26 Oct 2026, 15:04 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/kitabisa/teler-waf 0.1.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/kitabisa/teler-waf: affected < 0.1.1; fixed in 0.1.1 ## Suggested inspection (read-only) - Go github.com/kitabisa/teler-waf: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/kitabisa/teler-waf. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9f95-hhg4-pg4f (GitHub-reviewed advisory GHSA-9f95-hhg4-pg4f lists affected ranges: Go github.com/kitabisa/teler-waf >=0 <0.1.1) Commands are suggestions: review each one before running it.
Loading voting…