GeoServer style upload functionality vulnerable to XML External Entity (XXE) injection
CVE-2023-26043GHSA-mcmc-c59m-pqq8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (geonode 4.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI geonode
- Affected
- < 4.0.3
- Fixed in
- 4.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mcmc-c59m-pqq8 lists affected ranges: PyPI geonode >=0 <4.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mcmc-c59m-pqq8 lists affected ranges: PyPI geonode >=0 <4.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2023-26043: 0.84% estimated exploitation activity in the next 30 days; percentile 57.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary GeoNode is vulnerable to an XML External Entity (XXE) injection in the style upload functionality of GeoServer leading to Arbitrary File Read. Details GeoNode's GeoServer has the ability to upload new styles for datasets through the datasetstyleupload view. datasetstyleupload gets a user-provided file (1), pass it to extractnamefromsld to extract an element from it (2) and return the former in the response (3). extractnamefromsld uses sld (which is a path to the provided file), reads it (1) and parses it with etree.XML in 2. Since the former uses a default XMLParser, the parsing gets done with the resolveentities flag set to True. Therefore, dom handles the parsed XML containing the resolved entity (2), gets NamedLayer.UserStyle.Name in 3 and returns the resolved content in 4. PoC 1. Create a guest/non-privileged account and log in. 1. Upload a dataset through /catalogue/#/upload/dataset whose name we will be referencing as <DATASETNAME. 1. Send the following request that…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mcmc-c59m-pqq8
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mcmc-c59m-pqq8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-26043 Advisory: GeoServer style upload functionality vulnerable to XML External Entity (XXE) injection IDs: CVE-2023-26043, GHSA-mcmc-c59m-pqq8 Record: https://patchnext.com/advisories/cve-2023-26043 (revision 3, source checked 26 Oct 2026, 13:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: geonode 4.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI geonode: affected < 4.0.3; fixed in 4.0.3 ## Suggested inspection (read-only) - `python -m pip show geonode`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on geonode. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mcmc-c59m-pqq8 (OSV record GHSA-mcmc-c59m-pqq8 lists affected ranges: PyPI geonode >=0 <4.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-mcmc-c59m-pqq8 (GitHub-reviewed advisory GHSA-mcmc-c59m-pqq8 lists affected ranges: PyPI geonode >=0 <4.0.3) Commands are suggestions: review each one before running it.
Loading voting…