jsreport vulnerable to code injection
CVE-2023-2583GHSA-g7rj-q722-245g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jsreport 3.11.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm jsreport
- Affected
- < 3.11.3
- Fixed in
- 3.11.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g7rj-q722-245g lists affected ranges: npm jsreport >=0 <3.11.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g7rj-q722-245g lists affected ranges: npm jsreport >=0 <3.11.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-2583: 1.13% estimated exploitation activity in the next 30 days; percentile 66.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
jsreport prior to 3.11.3 had a version of vm2 vulnerable to CVE-2023-29017 hard coded in the package.json of the jsreport-core component. An attacker can use this vulnerability to obtain the authority of the jsreport playground server, or construct a malicious webpage/html file and send it to the user to attack the installed jsreport client.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-g7rj-q722-245g
- Revision 1 · created ·
Published from osv record GHSA-g7rj-q722-245g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-2583 Advisory: jsreport vulnerable to code injection IDs: CVE-2023-2583, GHSA-g7rj-q722-245g Record: https://patchnext.com/advisories/cve-2023-2583 (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jsreport 3.11.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm jsreport: affected < 3.11.3; fixed in 3.11.3 ## Suggested inspection (read-only) - `npm ls jsreport --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jsreport. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g7rj-q722-245g (OSV record GHSA-g7rj-q722-245g lists affected ranges: npm jsreport >=0 <3.11.3 (fixed)) - Verified: https://github.com/advisories/GHSA-g7rj-q722-245g (GitHub-reviewed advisory GHSA-g7rj-q722-245g lists affected ranges: npm jsreport >=0 <3.11.3) Commands are suggestions: review each one before running it.
Loading voting…