Skip to content

← Actionable
Critical, CVSS 10.0amended

Sequelize vulnerable to SQL Injection via replacements

CVE-2023-25813GHSA-wrh9-cjv3-2hpw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sequelize 6.19.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-25813: 1.44% estimated exploitation activity in the next 30 days; percentile 73.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The SQL injection exploit is related to replacements. Here is such an example: In the following query, some parameters are passed through replacements, and some are passed directly through the where option. This is a very legitimate use case, but this query was vulnerable to SQL injection due to how Sequelize processed the query: Sequelize built a first query using the where option, then passed it over to sequelize.query which parsed the resulting SQL to inject all :replacements. If the user passed values such as Sequelize would first generate this query: Then would inject replacements in it, which resulted in this: As you can see this resulted in arbitrary user-provided SQL being executed. Patches The issue was fixed in Sequelize 6.19.1 Workarounds Do not use the replacements and the where option in the same query if you are not using Sequelize = 6.19.1 References See this thread for more information: https://github.com/sequelize/sequelize/issues/14519 Snyk:…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-wrh9-cjv3-2hpw

  2. Revision 1 · created ·

    Published from osv record GHSA-wrh9-cjv3-2hpw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-25813

Advisory: Sequelize vulnerable to SQL Injection via replacements
IDs: CVE-2023-25813, GHSA-wrh9-cjv3-2hpw
Record: https://patchnext.com/advisories/cve-2023-25813 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sequelize 6.19.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm sequelize: affected < 6.19.1; fixed in 6.19.1

## Suggested inspection (read-only)
- `npm ls sequelize --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sequelize.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-wrh9-cjv3-2hpw (OSV record GHSA-wrh9-cjv3-2hpw lists affected ranges: npm sequelize >=0 <6.19.1 (fixed))
- Verified: https://github.com/advisories/GHSA-wrh9-cjv3-2hpw (GitHub-reviewed advisory GHSA-wrh9-cjv3-2hpw lists affected ranges: npm sequelize >=0 <6.19.1)

Commands are suggestions: review each one before running it.

Loading voting…