Skip to content

← Actionable
Medium, CVSS 5.5

Veracode Scan Jenkins Plugin vulnerable to information disclosure

CVE-2023-25722GHSA-fjrv-vx9m-4jpj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.veracode.jenkins:veracode-scan 23.3.19.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-25722: 0.21% estimated exploitation activity in the next 30 days; percentile 10.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Veracode Scan Jenkins Plugin before 23.3.19.0, when configured for remote agent jobs, invokes the Veracode Java API Wrapper in a manner that allows local users (with OS-level access of the Jenkins remote) to discover Veracode API credentials by listing the process and its arguments.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fjrv-vx9m-4jpj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-25722

Advisory: Veracode Scan Jenkins Plugin vulnerable to information disclosure
IDs: CVE-2023-25722, GHSA-fjrv-vx9m-4jpj
Record: https://patchnext.com/advisories/cve-2023-25722 (revision 1, source checked 26 Oct 2026, 16:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.veracode.jenkins:veracode-scan 23.3.19.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.veracode.jenkins:veracode-scan: affected < 23.3.19.0; fixed in 23.3.19.0

## Suggested inspection (read-only)
- Maven com.veracode.jenkins:veracode-scan: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.veracode.jenkins:veracode-scan.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fjrv-vx9m-4jpj (GitHub-reviewed advisory GHSA-fjrv-vx9m-4jpj lists affected ranges: Maven com.veracode.jenkins:veracode-scan >=0 <23.3.19.0)

Commands are suggestions: review each one before running it.

Loading voting…