Apache Airflow Hive Provider Improper Input Validation vulnerability
CVE-2023-25696GHSA-9mwf-mw74-9cv5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-apache-hive 5.1.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow-providers-apache-hive
- Affected
- < 5.1.3
- Fixed in
- 5.1.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9mwf-mw74-9cv5 lists affected ranges: PyPI apache-airflow-providers-apache-hive >=0 <5.1.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9mwf-mw74-9cv5 lists affected ranges: PyPI apache-airflow-providers-apache-hive >=0 <5.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-25696: 1.98% estimated exploitation activity in the next 30 days; percentile 80.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Input Validation vulnerability in the Apache Airflow Hive Provider. This issue affects Apache Airflow Hive Provider versions before 5.1.3.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from osv record GHSA-9mwf-mw74-9cv5
- Revision 3 · amended ·
Amended from ghsa record GHSA-9mwf-mw74-9cv5
- Revision 2 · amended ·
Amended from ghsa record GHSA-9mwf-mw74-9cv5
- Revision 1 · created ·
Published from osv record GHSA-9mwf-mw74-9cv5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25696 Advisory: Apache Airflow Hive Provider Improper Input Validation vulnerability IDs: CVE-2023-25696, GHSA-9mwf-mw74-9cv5 Record: https://patchnext.com/advisories/cve-2023-25696 (revision 4, source checked 27 Oct 2026, 06:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-apache-hive 5.1.3. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow-providers-apache-hive: affected < 5.1.3; fixed in 5.1.3 ## Suggested inspection (read-only) - `python -m pip show apache-airflow-providers-apache-hive`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow-providers-apache-hive. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9mwf-mw74-9cv5 (OSV record GHSA-9mwf-mw74-9cv5 lists affected ranges: PyPI apache-airflow-providers-apache-hive >=0 <5.1.3 (fixed)) - Verified: https://github.com/advisories/GHSA-9mwf-mw74-9cv5 (GitHub-reviewed advisory GHSA-9mwf-mw74-9cv5 lists affected ranges: PyPI apache-airflow-providers-apache-hive >=0 <5.1.3) Commands are suggestions: review each one before running it.
Loading voting…