TensorFlow has Floating Point Exception in AudioSpectrogram
CVE-2023-25666GHSA-f637-vh3r-vfh2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.11.1; tensorflow-gpu 2.11.1; tensorflow-cpu 2.11.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI tensorflow
- Affected
- < 2.11.1
- Fixed in
- 2.11.1
PyPI tensorflow-gpu
- Affected
- < 2.11.1
- Fixed in
- 2.11.1
PyPI tensorflow-cpu
- Affected
- < 2.11.1
- Fixed in
- 2.11.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-f637-vh3r-vfh2 lists affected ranges: PyPI tensorflow >=0 =0 =0 <2.11.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-f637-vh3r-vfh2 lists affected ranges: PyPI tensorflow >=0 =0 =0 <2.11.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-25666: 0.39% estimated exploitation activity in the next 30 days; percentile 32.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact version:2.11.0 //core/ops/audioops.cc:70 Status SpectrogramShapeFn(InferenceContext c) { ShapeHandle input; TFRETURNIFERROR(c-WithRank(c-input(0), 2, &input)); int32t windowsize; TFRETURNIFERROR(c-GetAttr("windowsize", &windowsize)); int32t stride; TFRETURNIFERROR(c-GetAttr("stride", &stride)); .....[1] DimensionHandle inputlength = c-Dim(input, 0); DimensionHandle inputchannels = c-Dim(input, 1); DimensionHandle outputlength; if (!c-ValueKnown(inputlength)) { outputlength = c-UnknownDim(); } else { const int64t inputlengthvalue = c-Value(inputlength); const int64t lengthminuswindow = (inputlengthvalue - windowsize); int64t outputlengthvalue; if (lengthminuswindow < 0) { outputlengthvalue = 0; } else { outputlengthvalue = 1 + (lengthminuswindow / stride); .....[2] } outputlength = c-MakeDim(outputlengthvalue); } Get the value of stride at [1], and the used at [2] Patches We have patched the issue in GitHub commit d0d4e779da0d0f56499c6fa5ba09f0a576cc6b14. The fix will be…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-f637-vh3r-vfh2
- Revision 1 · created ·
Published from osv record GHSA-f637-vh3r-vfh2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25666 Advisory: TensorFlow has Floating Point Exception in AudioSpectrogram IDs: CVE-2023-25666, GHSA-f637-vh3r-vfh2 Record: https://patchnext.com/advisories/cve-2023-25666 (revision 2, source checked 26 Oct 2026, 13:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.11.1; tensorflow-gpu 2.11.1; tensorflow-cpu 2.11.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI tensorflow: affected < 2.11.1; fixed in 2.11.1 - PyPI tensorflow-gpu: affected < 2.11.1; fixed in 2.11.1 - PyPI tensorflow-cpu: affected < 2.11.1; fixed in 2.11.1 ## Suggested inspection (read-only) - `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active. - `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-f637-vh3r-vfh2 (OSV record GHSA-f637-vh3r-vfh2 lists affected ranges: PyPI tensorflow >=0 =0 =0 <2.11.1 (fixed)) - Verified: https://github.com/advisories/GHSA-f637-vh3r-vfh2 (GitHub-reviewed advisory GHSA-f637-vh3r-vfh2 lists affected ranges: PyPI tensorflow >=0 =0 =0 <2.11.1) Commands are suggestions: review each one before running it.
Loading voting…