Skip to content

← Actionable
Medium, CVSS 6.5amended

TensorFlow Denial of Service vulnerability

CVE-2023-25661GHSA-fxgc-95xx-grvq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.11.1; tensorflow-cpu 2.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-25661: 0.44% estimated exploitation activity in the next 30 days; percentile 37.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A malicious invalid input crashes a tensorflow model (Check Failed) and can be used to trigger a denial of service attack. To minimize the bug, we built a simple single-layer TensorFlow model containing a Convolution3DTranspose layer, which works well with expected inputs and can be deployed in real-world systems. However, if we call the model with a malicious input which has a zero dimension, it gives Check Failed failure and crashes. This Convolution3DTranspose layer is a very common API in modern neural networks. The ML models containing such vulnerable components could be deployed in ML applications or as cloud services. This failure could be potentially used to trigger a denial of service attack on ML cloud services. Patches We have patched the issue in - GitHub commit 948fe6369a5711d4b4568ea9bbf6015c6dfb77e2 - GitHub commit 85db5d07db54b853484bfd358c3894d948c36baf. The fix will be included in TensorFlow 2.12.0. We will also cherrypick this commit on TensorFlow 2.11.1 For…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-fxgc-95xx-grvq

  2. Revision 1 · created ·

    Published from osv record GHSA-fxgc-95xx-grvq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-25661

Advisory: TensorFlow Denial of Service vulnerability
IDs: CVE-2023-25661, GHSA-fxgc-95xx-grvq
Record: https://patchnext.com/advisories/cve-2023-25661 (revision 2, source checked 26 Oct 2026, 13:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.11.1; tensorflow-cpu 2.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected < 2.11.1; fixed in 2.11.1
- PyPI tensorflow-cpu: affected < 2.11.1; fixed in 2.11.1

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-fxgc-95xx-grvq (OSV record GHSA-fxgc-95xx-grvq lists affected ranges: PyPI tensorflow >=0 =0 <2.11.1 (fixed))
- Verified: https://github.com/advisories/GHSA-fxgc-95xx-grvq (GitHub-reviewed advisory GHSA-fxgc-95xx-grvq lists affected ranges: PyPI tensorflow >=0 =0 <2.11.1)

Commands are suggestions: review each one before running it.

Loading voting…