Skip to content

← Actionable
High, CVSS 7.5amended

TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch

CVE-2023-25659GHSA-93vr-9q9m-pj8p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (tensorflow 2.11.1; tensorflow-gpu 2.11.1; tensorflow-cpu 2.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-25659: 0.39% estimated exploitation activity in the next 30 days; percentile 33.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact If the parameter indices for DynamicStitch does not match the shape of the parameter data, it can trigger an stack OOB read. Patches We have patched the issue in GitHub commit ee004b18b976eeb5a758020af8880236cd707d05. The fix will be included in TensorFlow 2.12. We will also cherrypick this commit on TensorFlow 2.11.1. For more information Please consult our security guide for more information regarding the security model and how to contact us with issues and questions. Attribution This has been reported via Google OSS VRP.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-93vr-9q9m-pj8p

  2. Revision 1 · created ·

    Published from osv record GHSA-93vr-9q9m-pj8p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-25659

Advisory: TensorFlow vulnerable to Out-of-Bounds Read in DynamicStitch
IDs: CVE-2023-25659, GHSA-93vr-9q9m-pj8p
Record: https://patchnext.com/advisories/cve-2023-25659 (revision 2, source checked 26 Oct 2026, 13:11 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: tensorflow 2.11.1; tensorflow-gpu 2.11.1; tensorflow-cpu 2.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI tensorflow: affected < 2.11.1; fixed in 2.11.1
- PyPI tensorflow-gpu: affected < 2.11.1; fixed in 2.11.1
- PyPI tensorflow-cpu: affected < 2.11.1; fixed in 2.11.1

## Suggested inspection (read-only)
- `python -m pip show tensorflow`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-gpu`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show tensorflow-cpu`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on tensorflow, tensorflow-gpu, tensorflow-cpu.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-93vr-9q9m-pj8p (OSV record GHSA-93vr-9q9m-pj8p lists affected ranges: PyPI tensorflow >=0 =0 =0 <2.11.1 (fixed))
- Verified: https://github.com/advisories/GHSA-93vr-9q9m-pj8p (GitHub-reviewed advisory GHSA-93vr-9q9m-pj8p lists affected ranges: PyPI tensorflow >=0 =0 =0 <2.11.1)

Commands are suggestions: review each one before running it.

Loading voting…