baserCMS File Uploader Remote Code Execution (RCE) vulnerability
CVE-2023-25654GHSA-h4cc-fxpp-pgw9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (baserproject/basercms 4.7.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist baserproject/basercms
- Affected
- < 4.7.5
- Fixed in
- 4.7.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h4cc-fxpp-pgw9 lists affected ranges: Packagist baserproject/basercms >=0 <4.7.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-25654: 1.53% estimated exploitation activity in the next 30 days; percentile 74.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact There is a Remote Code Execution (RCE) Vulnerability on the management system of baserCMS. Target baserCMS 4.7.3 and earlier versions Patches Update to the latest version of baserCMS Credits 島峰泰平@三井物産セキュアディレクション株式会社
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h4cc-fxpp-pgw9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25654 Advisory: baserCMS File Uploader Remote Code Execution (RCE) vulnerability IDs: CVE-2023-25654, GHSA-h4cc-fxpp-pgw9 Record: https://patchnext.com/advisories/cve-2023-25654 (revision 1, source checked 26 Oct 2026, 14:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: baserproject/basercms 4.7.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist baserproject/basercms: affected < 4.7.5; fixed in 4.7.5 ## Suggested inspection (read-only) - Packagist baserproject/basercms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on baserproject/basercms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h4cc-fxpp-pgw9 (GitHub-reviewed advisory GHSA-h4cc-fxpp-pgw9 lists affected ranges: Packagist baserproject/basercms >=0 <4.7.5) Commands are suggestions: review each one before running it.
Loading voting…