Improper calculations in ECC implementation can trigger a Denial-of-Service (DoS)
CVE-2023-25653GHSA-5h4j-qrvg-9xhw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node-jose 2.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm node-jose
- Affected
- < 2.2.0
- Fixed in
- 2.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5h4j-qrvg-9xhw lists affected ranges: npm node-jose >=0 <2.2.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5h4j-qrvg-9xhw lists affected ranges: npm node-jose >=0 <2.2.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-25653: 0.55% estimated exploitation activity in the next 30 days; percentile 46.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Description When using the non-default "fallback" crypto back-end, ECC operations in node-jose can trigger a Denial-of-Service (DoS) condition, due to a possible infinite loop in an internal calculation. For some ECC operations, this condition is triggered randomly; for others, it can be triggered by malicious input. Technical summary The JOSE logic implemented by node-jose usually relies on an external cryptographic library for the underlying cryptographic primitives that JOSE operations require. When WebCrypto or the Node crypto module are available, they are used. When neither of these libraries is available, node-jose includes its own "fallback" implementations of some algorithms based on node-forge, in particular implementations of ECDH and ECDSA. A various points, these algorithm implementations need to compute to the X coordinate of an elliptic curve point. This is done by calling the getX() method of the object representing the point, which is an alias of the function…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5h4j-qrvg-9xhw
- Revision 1 · created ·
Published from osv record GHSA-5h4j-qrvg-9xhw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25653 Advisory: Improper calculations in ECC implementation can trigger a Denial-of-Service (DoS) IDs: CVE-2023-25653, GHSA-5h4j-qrvg-9xhw Record: https://patchnext.com/advisories/cve-2023-25653 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node-jose 2.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm node-jose: affected < 2.2.0; fixed in 2.2.0 ## Suggested inspection (read-only) - `npm ls node-jose --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node-jose. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5h4j-qrvg-9xhw (OSV record GHSA-5h4j-qrvg-9xhw lists affected ranges: npm node-jose >=0 <2.2.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5h4j-qrvg-9xhw (GitHub-reviewed advisory GHSA-5h4j-qrvg-9xhw lists affected ranges: npm node-jose >=0 <2.2.0) Commands are suggestions: review each one before running it.
Loading voting…