Skip to content

← Actionable
High, CVSS 7.5amended

High resource usage when parsing multipart form data with many fields

CVE-2023-25577GHSA-xg9f-g7g7-2323

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (werkzeug 2.2.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI werkzeug

    Affected
    < 2.2.3
    Fixed in
    2.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-25577: 1.42% estimated exploitation activity in the next 30 days; percentile 72.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Werkzeug's multipart form data parser will parse an unlimited number of parts, including file parts. Parts can be a small amount of bytes, but each requires CPU time to parse and may use more memory as Python data. If a request can be made to an endpoint that accesses request.data, request.form, request.files, or request.getdata(parseformdata=False), it can cause unexpectedly high resource usage. This allows an attacker to cause a denial of service by sending crafted multipart data to an endpoint that will parse it. The amount of CPU time required can block worker processes from handling legitimate requests. The amount of RAM required can trigger an out of memory kill of the process. Unlimited file parts can use up memory and file handles. If many concurrent requests are sent continuously, this can exhaust or kill all available workers.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-xg9f-g7g7-2323

  2. Revision 1 · created ·

    Published from osv record GHSA-xg9f-g7g7-2323

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-25577

Advisory: High resource usage when parsing multipart form data with many fields
IDs: CVE-2023-25577, GHSA-xg9f-g7g7-2323
Record: https://patchnext.com/advisories/cve-2023-25577 (revision 2, source checked 26 Oct 2026, 13:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: werkzeug 2.2.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI werkzeug: affected < 2.2.3; fixed in 2.2.3

## Suggested inspection (read-only)
- `python -m pip show werkzeug`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on werkzeug.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-xg9f-g7g7-2323 (OSV record GHSA-xg9f-g7g7-2323 lists affected ranges: PyPI werkzeug >=0 <2.2.3 (fixed))
- Verified: https://github.com/advisories/GHSA-xg9f-g7g7-2323 (GitHub-reviewed advisory GHSA-xg9f-g7g7-2323 lists affected ranges: PyPI werkzeug >=0 <2.2.3)

Commands are suggestions: review each one before running it.

Loading voting…