Skip to content

← Actionable
High, CVSS 7.5amended

Denial of service due to unlimited number of parts

CVE-2023-25576GHSA-hpp2-2cr5-pf6g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@fastify/multipart 7.4.1, 6.0.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-25576: 1.46% estimated exploitation activity in the next 30 days; percentile 73.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The multipart body parser accepts an unlimited number of file parts. The multipart body parser accepts an unlimited number of field parts. The multipart body parser accepts an unlimited number of empty parts as field parts. Patches This is fixed in v7.4.1 (for Fastify v4.x) and v6.0.1 (for Fastify v3.x). Workarounds There are no known workaround. References Reported at https://hackerone.com/reports/1816195.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hpp2-2cr5-pf6g

  2. Revision 1 · created ·

    Published from osv record GHSA-hpp2-2cr5-pf6g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-25576

Advisory: Denial of service due to unlimited number of parts
IDs: CVE-2023-25576, GHSA-hpp2-2cr5-pf6g
Record: https://patchnext.com/advisories/cve-2023-25576 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @fastify/multipart 7.4.1, 6.0.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @fastify/multipart: affected < 6.0.1; >= 7.0.0, < 7.4.1; fixed in 6.0.1, 7.4.1

## Suggested inspection (read-only)
- `npm ls @fastify/multipart --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @fastify/multipart.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hpp2-2cr5-pf6g (OSV record GHSA-hpp2-2cr5-pf6g lists affected ranges: npm @fastify/multipart >=0 =7.0.0 <7.4.1 (fixed))
- Verified: https://github.com/advisories/GHSA-hpp2-2cr5-pf6g (GitHub-reviewed advisory GHSA-hpp2-2cr5-pf6g lists affected ranges: npm @fastify/multipart >=0 =7.0.0 <7.4.1)

Commands are suggestions: review each one before running it.

Loading voting…