Skip to content

← Actionable
High, CVSS 7.7

api-platform/core's secured properties may be accessible within collections

CVE-2023-25575GHSA-vr2x-7687-h6qv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (api-platform/core 3.1.3, 3.0.12, 2.7.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist api-platform/core

    Affected
    >= 3.0.0, < 3.0.12>= 3.1.0, < 3.1.3>= 2.6.0, < 2.7.10
    Fixed in
    2.7.10, 3.1.3, 3.0.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2023-25575: 0.60% estimated exploitation activity in the next 30 days; percentile 48.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Resource properties secured with the security option of the ApiPlatform\Metadata\ApiProperty attribute can be disclosed to unauthorized users. The problem affects most serialization formats, including raw JSON, which is enabled by default when installing API Platform. Custom serialization formats may also be impacted. Only collection endpoints are affected by the issue, item endpoints are not. The JSON-LD format is not affected by the issue. The result of the security rule is only executed for the first item of the collection. The result of the rule is then cached and reused for the next items. This bug can leak data to unauthorized users when the rule depends on the value of a property of the item. This bug can also hide properties that should be displayed to authorized users. Patches This issue impacts the 2.7, 3.0 and 3.1 branches. Upgrade to v2.7.10, v3.0.12 or v3.1.3. Workarounds Replace the cachekey of the context array of the Serializer inside a custom normalizer that…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vr2x-7687-h6qv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-25575

Advisory: api-platform/core's secured properties may be accessible within collections
IDs: CVE-2023-25575, GHSA-vr2x-7687-h6qv
Record: https://patchnext.com/advisories/cve-2023-25575 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: api-platform/core 3.1.3, 3.0.12, 2.7.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist api-platform/core: affected >= 3.0.0, < 3.0.12; >= 3.1.0, < 3.1.3; >= 2.6.0, < 2.7.10; fixed in 2.7.10, 3.1.3, 3.0.12

## Suggested inspection (read-only)
- Packagist api-platform/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on api-platform/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vr2x-7687-h6qv (GitHub-reviewed advisory GHSA-vr2x-7687-h6qv lists affected ranges: Packagist api-platform/core >=3.0.0 =3.1.0 =2.6.0 <2.7.10)

Commands are suggestions: review each one before running it.

Loading voting…