LTI JupyterHub Authenticator does not properly validate JWT Signature
CVE-2023-25574GHSA-mcgx-2gcr-p3hp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterhub-ltiauthenticator 1.4.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyterhub-ltiauthenticator
- Affected
- >= 1.3.0, <= 1.3.0
- Fixed in
- 1.4.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mcgx-2gcr-p3hp lists affected ranges: PyPI jupyterhub-ltiauthenticator >=1.3.0 <1.4.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mcgx-2gcr-p3hp lists affected ranges: PyPI jupyterhub-ltiauthenticator >=1.3.0 <=1.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2023-25574: 0.36% estimated exploitation activity in the next 30 days; percentile 29.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Only users that has configured a JupyterHub installation to use the authenticator class LTI13Authenticator are influenced. LTI13Authenticator that was introduced in jupyterhub-ltiauthenticator 1.3.0 wasn't validating JWT signatures. This is believed to allow the LTI13Authenticator to authorize a forged request granting access to existing and new user identities. Patches None. Workarounds None. References - This code segment didn't validate a JWT signature.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mcgx-2gcr-p3hp
- Revision 1 · created ·
Published from osv record GHSA-mcgx-2gcr-p3hp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25574 Advisory: LTI JupyterHub Authenticator does not properly validate JWT Signature IDs: CVE-2023-25574, GHSA-mcgx-2gcr-p3hp Record: https://patchnext.com/advisories/cve-2023-25574 (revision 2, source checked 26 Oct 2026, 13:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyterhub-ltiauthenticator 1.4.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyterhub-ltiauthenticator: affected >= 1.3.0, <= 1.3.0; fixed in 1.4.0 ## Suggested inspection (read-only) - `python -m pip show jupyterhub-ltiauthenticator`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyterhub-ltiauthenticator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mcgx-2gcr-p3hp (OSV record GHSA-mcgx-2gcr-p3hp lists affected ranges: PyPI jupyterhub-ltiauthenticator >=1.3.0 <1.4.0 (fixed)) - Verified: https://github.com/advisories/GHSA-mcgx-2gcr-p3hp (GitHub-reviewed advisory GHSA-mcgx-2gcr-p3hp lists affected ranges: PyPI jupyterhub-ltiauthenticator >=1.3.0 <=1.3.0) Commands are suggestions: review each one before running it.
Loading voting…