Cross site scripting Vulnerability in backstage Software Catalog
CVE-2023-25571GHSA-7hv8-3fr9-j2hv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@backstage/core-components 0.12.4; @backstage/plugin-catalog-backend 1.7.2; @backstage/catalog-model 1.2.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @backstage/core-components
- Affected
- < 0.12.4
- Fixed in
- 0.12.4
npm @backstage/plugin-catalog-backend
- Affected
- < 1.7.2
- Fixed in
- 1.7.2
- Affected
- < 1.2.0
- Fixed in
- 1.2.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7hv8-3fr9-j2hv lists affected ranges: npm @backstage/core-components >=0 =0 =0 <1.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7hv8-3fr9-j2hv lists affected ranges: npm @backstage/core-components >=0 =0 =0 <1.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N
- EPSS
- CVE-2023-25571: 0.45% estimated exploitation activity in the next 30 days; percentile 39.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact This vulnerability allows a malicious actor with access to add or modify content in an instance of the Backstage software catalog to inject script URLs in the entities stored in the catalog. If users of the catalog then click on said URLs, that can lead to an XSS attack. Patches This vulnerability has been patched in both the frontend and backend implementations. The default Link component from @backstage/core-components will now reject javascript: URLs, and there is a global override of window.open to do the same. In addition the catalog model as well as the catalog backend now has additional validation built in that prevents javascript: URLs in known annotations. Workarounds The general practice of limiting access to modifying catalog content and requiring code reviews greatly helps mitigate this vulnerability. For more information If you have any questions or comments about this advisory: Open an issue in the Backstage repository Visit our chat, linked to in the Backstage…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7hv8-3fr9-j2hv
- Revision 1 · created ·
Published from osv record GHSA-7hv8-3fr9-j2hv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25571 Advisory: Cross site scripting Vulnerability in backstage Software Catalog IDs: CVE-2023-25571, GHSA-7hv8-3fr9-j2hv Record: https://patchnext.com/advisories/cve-2023-25571 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @backstage/core-components 0.12.4; @backstage/plugin-catalog-backend 1.7.2; @backstage/catalog-model 1.2.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @backstage/core-components: affected < 0.12.4; fixed in 0.12.4 - npm @backstage/plugin-catalog-backend: affected < 1.7.2; fixed in 1.7.2 - npm @backstage/catalog-model: affected < 1.2.0; fixed in 1.2.0 ## Suggested inspection (read-only) - `npm ls @backstage/core-components --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @backstage/plugin-catalog-backend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls @backstage/catalog-model --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @backstage/core-components, @backstage/plugin-catalog-backend, @backstage/catalog-model. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7hv8-3fr9-j2hv (OSV record GHSA-7hv8-3fr9-j2hv lists affected ranges: npm @backstage/core-components >=0 =0 =0 <1.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-7hv8-3fr9-j2hv (GitHub-reviewed advisory GHSA-7hv8-3fr9-j2hv lists affected ranges: npm @backstage/core-components >=0 =0 =0 <1.7.2) Commands are suggestions: review each one before running it.
Loading voting…