Apollo has potential access control security issue in eureka
CVE-2023-25570GHSA-368x-wmmg-hq5c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.ctrip.framework.apollo:apollo 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.ctrip.framework.apollo:apollo
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-368x-wmmg-hq5c lists affected ranges: Maven com.ctrip.framework.apollo:apollo >=0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-25570: 0.82% estimated exploitation activity in the next 30 days; percentile 57.39 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact If users expose the apollo-configservice to the internet(which is not recommended), there are potential security issues since there is no authentication feature enabled for the built-in eureka service. Malicious hackers may access eureka directly to mock apollo-configservice and apollo-adminservice . Patches Login authentication for eureka was added in https://github.com/apolloconfig/apollo/pull/4663 and was released in v2.1.0. Workarounds To fix the potential issue without upgrading, simply follow the advice that does not expose apollo-configservice to the internet. References Apollo Security Guidence For more information If you have any questions or comments about this advisory: Open an issue in issue Email us at apollo-config@googlegroups.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-368x-wmmg-hq5c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25570 Advisory: Apollo has potential access control security issue in eureka IDs: CVE-2023-25570, GHSA-368x-wmmg-hq5c Record: https://patchnext.com/advisories/cve-2023-25570 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.ctrip.framework.apollo:apollo 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.ctrip.framework.apollo:apollo: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Maven com.ctrip.framework.apollo:apollo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.ctrip.framework.apollo:apollo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-368x-wmmg-hq5c (GitHub-reviewed advisory GHSA-368x-wmmg-hq5c lists affected ranges: Maven com.ctrip.framework.apollo:apollo >=0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…