apollo-portal has potential CSRF issue
CVE-2023-25569GHSA-fmxq-v8mg-qh25
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.ctrip.framework.apollo:apollo 2.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.ctrip.framework.apollo:apollo
- Affected
- < 2.1.0
- Fixed in
- 2.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fmxq-v8mg-qh25 lists affected ranges: Maven com.ctrip.framework.apollo:apollo >=0 <2.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.7 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-25569: 0.35% estimated exploitation activity in the next 30 days; percentile 28.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A low-privileged user can create a special web page. If an authenticated portal admin visits this page, the page can silently send a request to assign new roles for that user without any confirmation from the Portal admin. Patches Cookie SameSite strategy was set to Lax in #4664 and was released in v2.1.0. Workarounds To fix the potential issue without upgrading, simply follow the advice that does not visit unknown source pages. References Apollo Security Guidence For more information If you have any questions or comments about this advisory: Open an issue in issue Email us at apollo-config@googlegroups.com
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-fmxq-v8mg-qh25
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25569 Advisory: apollo-portal has potential CSRF issue IDs: CVE-2023-25569, GHSA-fmxq-v8mg-qh25 Record: https://patchnext.com/advisories/cve-2023-25569 (revision 1, source checked 26 Oct 2026, 16:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.ctrip.framework.apollo:apollo 2.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.ctrip.framework.apollo:apollo: affected < 2.1.0; fixed in 2.1.0 ## Suggested inspection (read-only) - Maven com.ctrip.framework.apollo:apollo: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.ctrip.framework.apollo:apollo. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-fmxq-v8mg-qh25 (GitHub-reviewed advisory GHSA-fmxq-v8mg-qh25 lists affected ranges: Maven com.ctrip.framework.apollo:apollo >=0 <2.1.0) Commands are suggestions: review each one before running it.
Loading voting…