Skip to content

← Actionable
High, CVSS 8.2

Boxo bitswap/server: DOS unbounded persistent memory leak

CVE-2023-25568GHSA-m974-xj4j-7qv5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/ipfs/go-libipfs 0.6.0, 0.4.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H
EPSS
  • CVE-2023-25568: 0.86% estimated exploitation activity in the next 30 days; percentile 58.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact An attacker is able allocate arbitrarily many bytes in the Bitswap server by sending many WANTBLOCK and or WANTHAVE requests which are queued in an unbounded queue, with allocations that persist even if the connection is closed. This affects users accepting untrusted connections with the Bitswap server, this also affects users using the old API stubs at github.com/ipfs/boxo/bitswap because it transitively uses github.com/ipfs/boxo/bitswap/server. We have renamed go-libipfs to boxo; this document uses both terms interchangeably. The version numbers for both are applicable, as they share the same historical timeline. Remediation Apply one of: - Update boxo to v0.6.0 or later - Update boxo to v0.4.1 Note that v0.5.0 is NOT safe, v0.4.1 is a backport of the v0.6.0 security fixes on top of v0.4.0. Mitigations 1. The server now limits how many wantlist entries per peer it knows. The MaxQueuedWantlistEntriesPerPeer option allows configuring how many wantlist entries the server…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m974-xj4j-7qv5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-25568

Advisory: Boxo bitswap/server: DOS unbounded persistent memory leak
IDs: CVE-2023-25568, GHSA-m974-xj4j-7qv5
Record: https://patchnext.com/advisories/cve-2023-25568 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/ipfs/go-libipfs 0.6.0, 0.4.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/ipfs/go-libipfs: affected >= 0.5.0, < 0.6.0; < 0.4.1; fixed in 0.6.0, 0.4.1

## Suggested inspection (read-only)
- Go github.com/ipfs/go-libipfs: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/ipfs/go-libipfs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m974-xj4j-7qv5 (GitHub-reviewed advisory GHSA-m974-xj4j-7qv5 lists affected ranges: Go github.com/ipfs/go-libipfs >=0.5.0 =0 <0.4.1)

Commands are suggestions: review each one before running it.

Loading voting…