Skip to content

← Actionable
Low, CVSS 3.5

Vaadin vulnerable to possible information disclosure of class and method names in RPC response

CVE-2023-25500GHSA-ch48-9r3q-pv7x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.vaadin:flow-server 24.1.0, 24.0.9, 23.3.13, 9.1.2, 2.9.3, 1.0.21; com.vaadin:vaadin 24.1.0, 24.0.7, 23.3.14, 22.1.0, 14.10.2, 10.0.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven com.vaadin:flow-server

    Affected
    >= 1.0.0, < 1.0.21>= 1.1.0, < 2.9.3>= 3.0.0, < 9.1.2>= 23.0.0, < 23.3.13>= 24.0.0, < 24.0.9>= 24.1.alpha1, < 24.1.0
    Fixed in
    2.9.3, 23.3.13, 1.0.21, 9.1.2, 24.1.0, 24.0.9
  • Maven com.vaadin:vaadin

    Affected
    >= 10.0.0, < 10.0.24>= 11.0.0, < 14.10.2>= 15.0.0, < 22.1.0>= 23.0.0, < 23.3.14>= 24.0.0, < 24.0.7>= 24.1.0.alpha1, < 24.1.0
    Fixed in
    24.0.7, 10.0.24, 22.1.0, 14.10.2, 23.3.14, 24.1.0

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-ch48-9r3q-pv7x lists affected ranges: Maven com.vaadin:flow-server >=1.0.0 =1.1.0 =3.0.0 =23.0.0 =24.0.0 =24.1.alpha1 =10.0.0 =11.0.0 =15.0.0 =23.0.0 =24.0.0 =24.1.0.alpha1 <24.1.0

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
EPSS
  • CVE-2023-25500: 0.51% estimated exploitation activity in the next 30 days; percentile 43.85 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Description Possible information disclosure in Vaadin 10.0.0 to 10.0.23, 11.0.0 to 14.10.1, 15.0.0 to 22.0.28, 23.0.0 to 23.3.13, 24.0.0 to 24.0.6, 24.1.0.alpha1 to 24.1.0.rc2, resulting in potential information disclosure of class and method names in RPC responses by sending modified requests. https://vaadin.com/security/cve-2023-25500

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-ch48-9r3q-pv7x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-25500

Advisory: Vaadin vulnerable to possible information disclosure of class and method names in RPC response
IDs: CVE-2023-25500, GHSA-ch48-9r3q-pv7x
Record: https://patchnext.com/advisories/cve-2023-25500 (revision 1, source checked 26 Oct 2026, 16:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: com.vaadin:flow-server 24.1.0, 24.0.9, 23.3.13, 9.1.2, 2.9.3, 1.0.21; com.vaadin:vaadin 24.1.0, 24.0.7, 23.3.14, 22.1.0, 14.10.2, 10.0.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven com.vaadin:flow-server: affected >= 1.0.0, < 1.0.21; >= 1.1.0, < 2.9.3; >= 3.0.0, < 9.1.2; >= 23.0.0, < 23.3.13; >= 24.0.0, < 24.0.9; >= 24.1.alpha1, < 24.1.0; fixed in 2.9.3, 23.3.13, 1.0.21, 9.1.2, 24.1.0, 24.0.9
- Maven com.vaadin:vaadin: affected >= 10.0.0, < 10.0.24; >= 11.0.0, < 14.10.2; >= 15.0.0, < 22.1.0; >= 23.0.0, < 23.3.14; >= 24.0.0, < 24.0.7; >= 24.1.0.alpha1, < 24.1.0; fixed in 24.0.7, 10.0.24, 22.1.0, 14.10.2, 23.3.14, 24.1.0

## Suggested inspection (read-only)
- Maven com.vaadin:flow-server: check the installed version with your package manager.
- Maven com.vaadin:vaadin: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on com.vaadin:flow-server, com.vaadin:vaadin.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-ch48-9r3q-pv7x (GitHub-reviewed advisory GHSA-ch48-9r3q-pv7x lists affected ranges: Maven com.vaadin:flow-server >=1.0.0 =1.1.0 =3.0.0 =23.0.0 =24.0.0 =24.1.alpha1 =10.0.0 =11.0.0 =15.0.0 =23.0.0 =24.0.0 =24.1.0.alpha1 <24.1.0)

Commands are suggestions: review each one before running it.

Loading voting…