Denial of service vulnerability on Password reset page
CVE-2023-25171GHSA-7j9h-3jxf-3vrf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (kiwitcms 12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI kiwitcms
- Affected
- < 12.0
- Fixed in
- 12.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-7j9h-3jxf-3vrf lists affected ranges: PyPI kiwitcms >=0 <12.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7j9h-3jxf-3vrf lists affected ranges: PyPI kiwitcms >=0 <12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-25171: 0.92% estimated exploitation activity in the next 30 days; percentile 60.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Previous versions of Kiwi TCMS do not impose rate limits which makes it easier to attempt denial-of-service attacks against the Password reset page. An attacker could potentially send a large number of emails if they know the email addresses of users in Kiwi TCMS. Additionally that may strain SMTP resources. Patches Users should upgrade to v12.0 or later. Workarounds Users may install and configure a rate-limiting proxy in front of Kiwi TCMS such as Nginx and/or configure rate limits on their email server when possible. References Disclosed by Ahmed Rabeaa Mosaa
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-7j9h-3jxf-3vrf
- Revision 1 · created ·
Published from osv record GHSA-7j9h-3jxf-3vrf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25171 Advisory: Denial of service vulnerability on Password reset page IDs: CVE-2023-25171, GHSA-7j9h-3jxf-3vrf Record: https://patchnext.com/advisories/cve-2023-25171 (revision 2, source checked 26 Oct 2026, 13:11 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: kiwitcms 12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI kiwitcms: affected < 12.0; fixed in 12.0 ## Suggested inspection (read-only) - `python -m pip show kiwitcms`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on kiwitcms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-7j9h-3jxf-3vrf (OSV record GHSA-7j9h-3jxf-3vrf lists affected ranges: PyPI kiwitcms >=0 <12.0 (fixed)) - Verified: https://github.com/advisories/GHSA-7j9h-3jxf-3vrf (GitHub-reviewed advisory GHSA-7j9h-3jxf-3vrf lists affected ranges: PyPI kiwitcms >=0 <12.0) Commands are suggestions: review each one before running it.
Loading voting…