Skip to content

← Actionable
Medium, CVSS 4.3

Helm vulnerable to information disclosure via getHostByName Function

CVE-2023-25165GHSA-pwcw-6f5g-gxf8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (helm.sh/helm/v3 3.11.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
  • CVE-2023-25165: 0.77% estimated exploitation activity in the next 30 days; percentile 55.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A Helm contributor discovered an information disclosure vulnerability using the getHostByName template function. Impact getHostByName is a Helm template function introduced in Helm v3. The function is able to accept a hostname and return an IP address for that hostname. To get the IP address the function performs a DNS lookup. The DNS lookup happens when used with helm install|upgrade|template or when the Helm SDK is used to render a chart. Information passed into the chart can be disclosed to the DNS servers used to lookup the IP address. For example, a malicious chart could inject getHostByName into a chart in order to disclose values to a malicious DNS server. Patches The issue has been fixed in Helm 3.11.1. Workarounds Prior to using a chart with Helm verify the getHostByName function is not being used in a template to disclose any information you do not want passed to DNS servers. For more information Helm's security policy is spelled out in detail in our SECURITY document.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pwcw-6f5g-gxf8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-25165

Advisory: Helm vulnerable to information disclosure via getHostByName Function
IDs: CVE-2023-25165, GHSA-pwcw-6f5g-gxf8
Record: https://patchnext.com/advisories/cve-2023-25165 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: helm.sh/helm/v3 3.11.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go helm.sh/helm/v3: affected >= 3.0.0, < 3.11.1; fixed in 3.11.1

## Suggested inspection (read-only)
- Go helm.sh/helm/v3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on helm.sh/helm/v3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pwcw-6f5g-gxf8 (GitHub-reviewed advisory GHSA-pwcw-6f5g-gxf8 lists affected ranges: Go helm.sh/helm/v3 >=3.0.0 <3.11.1)

Commands are suggestions: review each one before running it.

Loading voting…