Sensitive Information leak via Script File in TinaCMS
CVE-2023-25164GHSA-pc2q-jcxq-rjrr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@tinacms/cli 1.0.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @tinacms/cli
- Affected
- >= 1.0.0, < 1.0.9
- Fixed in
- 1.0.9
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pc2q-jcxq-rjrr lists affected ranges: npm @tinacms/cli >=1.0.0 <1.0.9 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pc2q-jcxq-rjrr lists affected ranges: npm @tinacms/cli >=1.0.0 <1.0.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.6 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- CVE-2023-25164: 0.68% estimated exploitation activity in the next 30 days; percentile 52.22 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Sensitive Information leaked via script File in TinaCMS. Sites building with @tinacms/cli = 1.0.0 && < 1.0.9 that store sensitive values in process.env var are impacted. If you're on a version prior to 1.0.0 this vulnerability does not affect you. If your Tina-enabled website has sensitive credentials stored as environment variables (eg. Algolia API keys) you should rotate those keys immediately. Patches This issue has been patched in @tinacms/cli@1.0.9 Workarounds Upgrading, and rotating secure & exposed keys is required for the proper fix. References https://github.com/tinacms/tinacms/pull/3584
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pc2q-jcxq-rjrr
- Revision 1 · created ·
Published from osv record GHSA-pc2q-jcxq-rjrr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25164 Advisory: Sensitive Information leak via Script File in TinaCMS IDs: CVE-2023-25164, GHSA-pc2q-jcxq-rjrr Record: https://patchnext.com/advisories/cve-2023-25164 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @tinacms/cli 1.0.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @tinacms/cli: affected >= 1.0.0, < 1.0.9; fixed in 1.0.9 ## Suggested inspection (read-only) - `npm ls @tinacms/cli --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @tinacms/cli. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pc2q-jcxq-rjrr (OSV record GHSA-pc2q-jcxq-rjrr lists affected ranges: npm @tinacms/cli >=1.0.0 <1.0.9 (fixed)) - Verified: https://github.com/advisories/GHSA-pc2q-jcxq-rjrr (GitHub-reviewed advisory GHSA-pc2q-jcxq-rjrr lists affected ranges: npm @tinacms/cli >=1.0.0 <1.0.9) Commands are suggestions: review each one before running it.
Loading voting…