GeoServer OGC Filter SQL Injection Vulnerabilities
CVE-2023-25157GHSA-7g5f-wrx8-5ccf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.geoserver.community:gs-jdbcconfig 2.22.2, 2.21.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.geoserver.community:gs-jdbcconfig
- Affected
- < 2.21.4>= 2.22.0, < 2.22.2
- Fixed in
- 2.22.2, 2.21.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7g5f-wrx8-5ccf lists affected ranges: Maven org.geoserver.community:gs-jdbcconfig >=0 =2.22.0 <2.22.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-25157: 85.25% estimated exploitation activity in the next 30 days; percentile 99.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact GeoServer includes support for the OGC Filter expression language and the OGC Common Query Language (CQL) as part of the Web Feature Service (WFS) and Web Map Service (WMS) protocols. CQL is also supported through the Web Coverage Service (WCS) protocol for ImageMosaic coverages. SQL Injection Vulnerabilities have been found with: PropertyIsLike filter, when used with a String field and any database DataStore, or with a PostGIS DataStore with encode functions enabled strEndsWith function, when used with a PostGIS DataStore with encode functions enabled strStartsWith function, when used with a PostGIS DataStore with encode functions enabled FeatureId filter, when used with any database table having a String primary key column and when prepared statements are disabled jsonArrayContains function, when used with a String or JSON field and with a PostGIS or Oracle DataStore (GeoServer 2.22.0+ only) DWithin filter, when used with an Oracle DataStore Patches GeoSever 2.21.4 GeoServer…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7g5f-wrx8-5ccf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25157 Advisory: GeoServer OGC Filter SQL Injection Vulnerabilities IDs: CVE-2023-25157, GHSA-7g5f-wrx8-5ccf Record: https://patchnext.com/advisories/cve-2023-25157 (revision 1, source checked 26 Oct 2026, 16:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.geoserver.community:gs-jdbcconfig 2.22.2, 2.21.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.geoserver.community:gs-jdbcconfig: affected < 2.21.4; >= 2.22.0, < 2.22.2; fixed in 2.22.2, 2.21.4 ## Suggested inspection (read-only) - Maven org.geoserver.community:gs-jdbcconfig: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.geoserver.community:gs-jdbcconfig. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7g5f-wrx8-5ccf (GitHub-reviewed advisory GHSA-7g5f-wrx8-5ccf lists affected ranges: Maven org.geoserver.community:gs-jdbcconfig >=0 =2.22.0 <2.22.2) Commands are suggestions: review each one before running it.
Loading voting…