OCI image importer memory exhaustion in github.com/containerd/containerd
CVE-2023-25153GHSA-259w-8hf6-59c2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/containerd/containerd 1.6.18, 1.5.18), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/containerd/containerd
- Affected
- >= 1.6.0, < 1.6.18< 1.5.18
- Fixed in
- 1.5.18, 1.6.18
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-259w-8hf6-59c2 lists affected ranges: Go github.com/containerd/containerd >=1.6.0 =0 <1.5.18
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- EPSS
- CVE-2023-25153: 0.36% estimated exploitation activity in the next 30 days; percentile 30.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact When importing an OCI image, there was no limit on the number of bytes read for certain files. A maliciously crafted image with a large file where a limit was not applied could cause a denial of service. Patches This bug has been fixed in containerd 1.6.18 and 1.5.18. Users should update to these versions to resolve the issue. Workarounds Ensure that only trusted images are used and that only trusted users have permissions to import images. Credits The containerd project would like to thank David Korczynski and Adam Korczynski of ADA Logics for responsibly disclosing this issue in accordance with the containerd security policy during a security fuzzing audit sponsored by CNCF. For more information If you have any questions or comments about this advisory: Open an issue in containerd Email us at security@containerd.io To report a security issue in containerd: Report a new vulnerability Email us at security@containerd.io
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-259w-8hf6-59c2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25153 Advisory: OCI image importer memory exhaustion in github.com/containerd/containerd IDs: CVE-2023-25153, GHSA-259w-8hf6-59c2 Record: https://patchnext.com/advisories/cve-2023-25153 (revision 1, source checked 26 Oct 2026, 15:05 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/containerd/containerd 1.6.18, 1.5.18. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/containerd/containerd: affected >= 1.6.0, < 1.6.18; < 1.5.18; fixed in 1.5.18, 1.6.18 ## Suggested inspection (read-only) - Go github.com/containerd/containerd: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/containerd/containerd. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-259w-8hf6-59c2 (GitHub-reviewed advisory GHSA-259w-8hf6-59c2 lists affected ranges: Go github.com/containerd/containerd >=1.6.0 =0 <1.5.18) Commands are suggestions: review each one before running it.
Loading voting…