Skip to content

← Actionable
High, CVSS 8.4

Pterodactyl Wings contains UNIX Symbolic Link (Symlink) Following

CVE-2023-25152GHSA-p8r3-83r8-jwj5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/pterodactyl/wings 1.11.3, 1.7.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:L/A:H
EPSS
  • CVE-2023-25152: 0.68% estimated exploitation activity in the next 30 days; percentile 52.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This vulnerability impacts anyone running the affected versions of Wings. The vulnerability can be used to create new files and on the host system that previously did not exist, potentially allowing attackers to change their resource allocations, promote their containers to privileged mode, or potentially add ssh authorized keys to allow the attacker access to a remote shell on the target machine. In order to use this exploit, an attacker must have an existing "server" allocated and controlled by Wings. Information on how the exploitation of this vulnerability works will be released on February 24th, 2023 in North America. Patches This vulnerability has been resolved in version v1.11.3 of Wings, and has been back-ported to the 1.7 release series in v1.7.3. Anyone running v1.11.x should upgrade to v1.11.3 and anyone running v1.7.x should upgrade to v1.7.3. Workarounds None at this time.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p8r3-83r8-jwj5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-25152

Advisory: Pterodactyl Wings contains UNIX Symbolic Link (Symlink) Following
IDs: CVE-2023-25152, GHSA-p8r3-83r8-jwj5
Record: https://patchnext.com/advisories/cve-2023-25152 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/pterodactyl/wings 1.11.3, 1.7.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/pterodactyl/wings: affected >= 1.11.0, < 1.11.3; < 1.7.3; fixed in 1.11.3, 1.7.3

## Suggested inspection (read-only)
- Go github.com/pterodactyl/wings: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/pterodactyl/wings.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p8r3-83r8-jwj5 (GitHub-reviewed advisory GHSA-p8r3-83r8-jwj5 lists affected ranges: Go github.com/pterodactyl/wings >=1.11.0 =0 <1.7.3)

Commands are suggestions: review each one before running it.

Loading voting…