Skip to content

← Actionable
Medium, CVSS 6.5amended

Buffer under-read in workerd

CVE-2023-2512GHSA-8vx6-69vg-c46f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (workerd 1.20230419.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm workerd

    Affected
    < 1.20230419.0
    Fixed in
    1.20230419.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:H
EPSS
  • CVE-2023-2512: 0.62% estimated exploitation activity in the next 30 days; percentile 49.60 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Prior to version v1.20230419.0, the FormData API implementation was subject to an integer overflow. If a FormData instance contained more than 2^31 elements, the forEach() method could end up reading from the wrong location in memory while iterating over elements. This would most likely lead to a segmentation fault, but could theoretically allow arbitrary undefined behavior. In order for the bug to be exploitable, the process would need to be able to allocate 160GB of RAM. Due to this, the bug was never exploitable on the Cloudflare Workers platform, but could theoretically be exploitable on deployments of workerd running on machines with a huge amount of memory. Moreover, in order to be remotely exploited, an attacker would have to upload a single form-encoded HTTP request of at least tens of gigabytes in size. The application code would then have to use request.formData() to parse the request and formData.forEach() to iterate over this data. Due to these limitations, the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-8vx6-69vg-c46f

  2. Revision 1 · created ·

    Published from osv record GHSA-8vx6-69vg-c46f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-2512

Advisory: Buffer under-read in workerd
IDs: CVE-2023-2512, GHSA-8vx6-69vg-c46f
Record: https://patchnext.com/advisories/cve-2023-2512 (revision 2, source checked 26 Oct 2026, 12:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: workerd 1.20230419.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm workerd: affected < 1.20230419.0; fixed in 1.20230419.0

## Suggested inspection (read-only)
- `npm ls workerd --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on workerd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-8vx6-69vg-c46f (OSV record GHSA-8vx6-69vg-c46f lists affected ranges: npm workerd >=0 <1.20230419.0 (fixed))
- Verified: https://github.com/advisories/GHSA-8vx6-69vg-c46f (GitHub-reviewed advisory GHSA-8vx6-69vg-c46f lists affected ranges: npm workerd >=0 <1.20230419.0)

Commands are suggestions: review each one before running it.

Loading voting…