Clockwork Web contains a Cross-Site Request Forgery Vulnerability with Rails < 5.2
CVE-2023-25015GHSA-p4xx-w6fr-c4w9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (clockwork_web 0.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems clockwork_web
- Affected
- < 0.1.2
- Fixed in
- 0.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p4xx-w6fr-c4w9 lists affected ranges: RubyGems clockwork_web >=0 <0.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2023-25015: 0.36% estimated exploitation activity in the next 30 days; percentile 29.61 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Clockwork Web before 0.1.2, when used with Rails before 5.2 is used, allows Cross-Site Request Forgery (CSRF). A CSRF attack works by getting an authorized user to visit a malicious website and then performing requests on behalf of the user. In this instance, actions include enabling and disabling jobs. All users running an affected release on Rails < 5.2 should upgrade immediately.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p4xx-w6fr-c4w9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-25015 Advisory: Clockwork Web contains a Cross-Site Request Forgery Vulnerability with Rails < 5.2 IDs: CVE-2023-25015, GHSA-p4xx-w6fr-c4w9 Record: https://patchnext.com/advisories/cve-2023-25015 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: clockwork_web 0.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems clockwork_web: affected < 0.1.2; fixed in 0.1.2 ## Suggested inspection (read-only) - RubyGems clockwork_web: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on clockwork_web. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p4xx-w6fr-c4w9 (GitHub-reviewed advisory GHSA-p4xx-w6fr-c4w9 lists affected ranges: RubyGems clockwork_web >=0 <0.1.2) Commands are suggestions: review each one before running it.
Loading voting…