Skip to content

← Actionable
Medium, CVSS 6.5

Credential disclosure in syft when SYFT_ATTEST_PASSWORD environment variable set

CVE-2023-24827GHSA-jp7v-3587-2956

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/anchore/syft 0.70.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2023-24827: 0.79% estimated exploitation activity in the next 30 days; percentile 56.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A password disclosure flaw was found in Syft versions v0.69.0 and v0.69.1. This flaw leaks the password stored in the SYFTATTESTPASSWORD environment variable. Impact The SYFTATTESTPASSWORD environment variable is for the syft attest command to generate attested SBOMs for the given container image. This environment variable is used to decrypt the private key (provided with syft attest --key <path-to-key-file) during the signing process while generating an SBOM attestation. This vulnerability affects users running syft that have the SYFTATTESTPASSWORD environment variable set with credentials (regardless of if the attest command is being used or not). Users that do not have the environment variable SYFTATTESTPASSWORD set are not affected by this issue. The credentials are leaked in two ways: - in the syft logs when -vv or -vvv are used in the syft command (which is any log level = DEBUG) - in the attestation or SBOM only when the syft-json format is used Note that as of v0.69.0 any…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jp7v-3587-2956

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-24827

Advisory: Credential disclosure in syft when SYFT_ATTEST_PASSWORD environment variable set
IDs: CVE-2023-24827, GHSA-jp7v-3587-2956
Record: https://patchnext.com/advisories/cve-2023-24827 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/anchore/syft 0.70.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/anchore/syft: affected >= 0.69.0, < 0.70.0; fixed in 0.70.0

## Suggested inspection (read-only)
- Go github.com/anchore/syft: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/anchore/syft.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jp7v-3587-2956 (GitHub-reviewed advisory GHSA-jp7v-3587-2956 lists affected ranges: Go github.com/anchore/syft >=0.69.0 <0.70.0)

Commands are suggestions: review each one before running it.

Loading voting…