Skip to content

← Actionable
High, CVSS 8.8

TYPO3 is vulnerable to Cross-Site Scripting via frontend rendering

CVE-2023-24814GHSA-r4f8-f93x-5qh3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms-core 12.2.0, 11.5.23, 10.4.36, 9.5.40, 8.7.51; typo3/cms 12.2.0, 11.5.23, 10.4.35), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms-core

    Affected
    >= 12.0.0, < 12.2.0>= 11.0.0, < 11.5.23>= 10.0.0, < 10.4.36>= 9.0.0, < 9.5.40>= 8.7.0, < 8.7.51
    Fixed in
    12.2.0, 8.7.51, 9.5.40, 10.4.36, 11.5.23
  • Packagist typo3/cms

    Affected
    >= 10.0.0, < 10.4.35>= 11.0.0, < 11.5.23>= 12.0.0, < 12.2.0
    Fixed in
    12.2.0, 10.4.35, 11.5.23

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-r4f8-f93x-5qh3 lists affected ranges: Packagist typo3/cms-core >=12.0.0 =11.0.0 =10.0.0 =9.0.0 =8.7.0 =10.0.0 =11.0.0 =12.0.0 <12.2.0

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:L
EPSS
  • CVE-2023-24814: 0.83% estimated exploitation activity in the next 30 days; percentile 57.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

CVSS: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:H/A:L/E:F/RL:O/RC:C (8.2) Problem TYPO3 core component GeneralUtility::getIndpEnv() uses the unfiltered server environment variable PATHINFO, which allows attackers to inject malicious content. In combination with the TypoScript setting config.absRefPrefix=auto, attackers can inject malicious HTML code into pages that have not yet been rendered and cached. As a result, injected values would be cached and delivered to other website visitors (persisted cross-site scripting). Individual code which relies on the resolved value of GeneralUtility::getIndpEnv('SCRIPTNAME') and corresponding usages (as shown below) are vulnerable as well. - GeneralUtility::getIndpEnv('PATHINFO') - GeneralUtility::getIndpEnv('SCRIPTNAME') - GeneralUtility::getIndpEnv('TYPO3REQUESTDIR') - GeneralUtility::getIndpEnv('TYPO3REQUESTSCRIPT') - GeneralUtility::getIndpEnv('TYPO3SITEPATH') - GeneralUtility::getIndpEnv('TYPO3SITESCRIPT') -…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-r4f8-f93x-5qh3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-24814

Advisory: TYPO3 is vulnerable to Cross-Site Scripting via frontend rendering
IDs: CVE-2023-24814, GHSA-r4f8-f93x-5qh3
Record: https://patchnext.com/advisories/cve-2023-24814 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms-core 12.2.0, 11.5.23, 10.4.36, 9.5.40, 8.7.51; typo3/cms 12.2.0, 11.5.23, 10.4.35. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms-core: affected >= 12.0.0, < 12.2.0; >= 11.0.0, < 11.5.23; >= 10.0.0, < 10.4.36; >= 9.0.0, < 9.5.40; >= 8.7.0, < 8.7.51; fixed in 12.2.0, 8.7.51, 9.5.40, 10.4.36, 11.5.23
- Packagist typo3/cms: affected >= 10.0.0, < 10.4.35; >= 11.0.0, < 11.5.23; >= 12.0.0, < 12.2.0; fixed in 12.2.0, 10.4.35, 11.5.23

## Suggested inspection (read-only)
- Packagist typo3/cms-core: check the installed version with your package manager.
- Packagist typo3/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms-core, typo3/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-r4f8-f93x-5qh3 (GitHub-reviewed advisory GHSA-r4f8-f93x-5qh3 lists affected ranges: Packagist typo3/cms-core >=12.0.0 =11.0.0 =10.0.0 =9.0.0 =8.7.0 =10.0.0 =11.0.0 =12.0.0 <12.2.0)

Commands are suggestions: review each one before running it.

Loading voting…