Skip to content

← Actionable
Critical, CVSS 10.0

URI validation failure on SVG parsing. Bypass of CVE-2023-23924

CVE-2023-24813GHSA-56gj-mvh6-rp75

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dompdf/dompdf 2.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-24813: 2.49% estimated exploitation activity in the next 30 days; percentile 84.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary Due to the difference in the attribute parser of Dompdf and php-svg-lib, an attacker can still call arbitrary URLs with arbitrary protocols. Details Dompdf parses the href attribute of image tags with the following code: src/Image/Cache.php line 135-150 As you can see from the code snippet above, it respects xlink:href even if href is specified. However, php-svg-lib, which is later used to parse the svg file, parses the href attribute with the following code: src/Svg/Tag/Image.php line 51-57 Since href is respected if both xlink:href and href is specified, it's possible to bypass the protection on the Dompdf side by providing an empty xlink:href attribute. Impact An attacker can exploit the vulnerability to call arbitrary URLs with arbitrary protocols if they provide an SVG file to the Dompdf. In PHP versions before 8.0.0, it leads to arbitrary unserialize, which will lead, at the very least, to arbitrary file deletion and might lead to remote code execution, depending on…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-56gj-mvh6-rp75

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-24813

Advisory: URI validation failure on SVG parsing. Bypass of CVE-2023-23924
IDs: CVE-2023-24813, GHSA-56gj-mvh6-rp75
Record: https://patchnext.com/advisories/cve-2023-24813 (revision 1, source checked 26 Oct 2026, 14:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dompdf/dompdf 2.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist dompdf/dompdf: affected >= 2.0.2, <= 2.0.2; fixed in 2.0.3

## Suggested inspection (read-only)
- Packagist dompdf/dompdf: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dompdf/dompdf.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-56gj-mvh6-rp75 (GitHub-reviewed advisory GHSA-56gj-mvh6-rp75 lists affected ranges: Packagist dompdf/dompdf >=2.0.2 <=2.0.2)

Commands are suggestions: review each one before running it.

Loading voting…