Skip to content

← Actionable
High, CVSS 7.5amended

Regular Expression Denial of Service in Headers

CVE-2023-24807GHSA-r6ch-mqf9-qc9w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 19.6.1, 18.14.1, 16.19.1, 14.21.3; undici 5.19.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • runtime node

    Affected
    >= 14.0.0, < 14.21.3>= 16.0.0, < 16.19.1>= 18.0.0, < 18.14.1>= 19.0.0, < 19.6.1
    Fixed in
    19.6.1, 18.14.1, 16.19.1, 14.21.3
  • npm undici

    Affected
    < 5.19.1
    Fixed in
    5.19.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2023-24807: 1.31% estimated exploitation activity in the next 30 days; percentile 70.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The Headers.set() and Headers.append() methods are vulnerable to Regular Expression Denial of Service (ReDoS) attacks when untrusted values are passed into the functions. This is due to the inefficient regular expression used to normalize the values in the headerValueNormalize() utility function. Patches This vulnerability was patched in v5.19.1. Workarounds There is no workaround. Please update to an unaffected version. References https://hackerone.com/bugs?reportid=1784449 Credits Carter Snook reported this vulnerability.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from vendor_advisory record nodejs-security-wg:core:106

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-r6ch-mqf9-qc9w

  3. Revision 1 · created ·

    Published from osv record GHSA-r6ch-mqf9-qc9w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-24807

Advisory: Regular Expression Denial of Service in Headers
IDs: CVE-2023-24807, GHSA-r6ch-mqf9-qc9w
Record: https://patchnext.com/advisories/cve-2023-24807 (revision 3, source checked 26 Oct 2026, 16:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node 19.6.1, 18.14.1, 16.19.1, 14.21.3; undici 5.19.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- runtime node: affected >= 14.0.0, < 14.21.3; >= 16.0.0, < 16.19.1; >= 18.0.0, < 18.14.1; >= 19.0.0, < 19.6.1; fixed in 19.6.1, 18.14.1, 16.19.1, 14.21.3
- npm undici: affected < 5.19.1; fixed in 5.19.1

## Suggested inspection (read-only)
- runtime node: check the installed version with your package manager.
- `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node, undici.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r6ch-mqf9-qc9w (OSV record GHSA-r6ch-mqf9-qc9w lists affected ranges: npm undici >=0 <5.19.1 (fixed))
- Verified: https://github.com/advisories/GHSA-r6ch-mqf9-qc9w (GitHub-reviewed advisory GHSA-r6ch-mqf9-qc9w lists affected ranges: npm undici >=0 <5.19.1)
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2023-24807 to 2023-02-16.)
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/106.json (Node.js security working group core entry 106 lists CVE-2023-24807 affecting node >=14.0.0 =16.0.0 =18.0.0 =19.0.0 <19.6.1)

Commands are suggestions: review each one before running it.

Loading voting…