Stored cross site scripting in changedetection.io
CVE-2023-24769GHSA-68wj-c2jw-5pp9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (changedetection-io 0.40.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI changedetection-io
- Affected
- < 0.40.2
- Fixed in
- 0.40.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-68wj-c2jw-5pp9 lists affected ranges: PyPI changedetection-io >=0 <0.40.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-68wj-c2jw-5pp9 lists affected ranges: PyPI changedetection-io >=0 <0.40.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 4.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2023-24769: 0.64% estimated exploitation activity in the next 30 days; percentile 50.57 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Changedetection.io before 0.40.2 was discovered to contain a stored cross-site scripting (XSS) vulnerability in the main page. This vulnerability allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the URL parameter under the "Add a new change detection watch" function.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-68wj-c2jw-5pp9
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-68wj-c2jw-5pp9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-24769 Advisory: Stored cross site scripting in changedetection.io IDs: CVE-2023-24769, GHSA-68wj-c2jw-5pp9 Record: https://patchnext.com/advisories/cve-2023-24769 (revision 3, source checked 26 Oct 2026, 13:31 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: changedetection-io 0.40.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI changedetection-io: affected < 0.40.2; fixed in 0.40.2 ## Suggested inspection (read-only) - `python -m pip show changedetection-io`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on changedetection-io. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-68wj-c2jw-5pp9 (OSV record GHSA-68wj-c2jw-5pp9 lists affected ranges: PyPI changedetection-io >=0 <0.40.2 (fixed)) - Verified: https://github.com/advisories/GHSA-68wj-c2jw-5pp9 (GitHub-reviewed advisory GHSA-68wj-c2jw-5pp9 lists affected ranges: PyPI changedetection-io >=0 <0.40.2) Commands are suggestions: review each one before running it.
Loading voting…