CSRF vulnerability in Jenkins Orka Plugin allow capturing credentials
CVE-2023-24432GHSA-9jwh-qvg7-gr59
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.jenkins.plugins:macstadium-orka 1.32), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.jenkins.plugins:macstadium-orka
- Affected
- < 1.32
- Fixed in
- 1.32
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9jwh-qvg7-gr59 lists affected ranges: Maven io.jenkins.plugins:macstadium-orka >=0 <1.32
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2023-24432: 0.52% estimated exploitation activity in the next 30 days; percentile 43.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A cross-site request forgery (CSRF) vulnerability in Jenkins Orka by MacStadium Plugin 1.31 and earlier allows attackers to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9jwh-qvg7-gr59
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-24432 Advisory: CSRF vulnerability in Jenkins Orka Plugin allow capturing credentials IDs: CVE-2023-24432, GHSA-9jwh-qvg7-gr59 Record: https://patchnext.com/advisories/cve-2023-24432 (revision 1, source checked 26 Oct 2026, 16:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.jenkins.plugins:macstadium-orka 1.32. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.jenkins.plugins:macstadium-orka: affected < 1.32; fixed in 1.32 ## Suggested inspection (read-only) - Maven io.jenkins.plugins:macstadium-orka: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.jenkins.plugins:macstadium-orka. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9jwh-qvg7-gr59 (GitHub-reviewed advisory GHSA-9jwh-qvg7-gr59 lists affected ranges: Maven io.jenkins.plugins:macstadium-orka >=0 <1.32) Commands are suggestions: review each one before running it.
Loading voting…