Skip to content

← Actionable
Critical, CVSS 9.1

Users with any cluster secret update access may update out-of-bounds cluster secrets

CVE-2023-23947GHSA-3jfq-742w-xg8j

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/argoproj/argo-cd 2.6.2, 2.5.11, 2.4.23, 2.3.17), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/argoproj/argo-cd

    Affected
    >= 2.3.0, < 2.3.17>= 2.4.0, < 2.4.23>= 2.5.0, < 2.5.11>= 2.6.0, < 2.6.2
    Fixed in
    2.4.23, 2.3.17, 2.5.11, 2.6.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2023-23947: 0.67% estimated exploitation activity in the next 30 days; percentile 52.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact All Argo CD versions starting with v2.3.0-rc1 are vulnerable to an improper authorization bug which allows users who have the ability to update at least one cluster secret to update any cluster secret. The attacker could use this access to escalate privileges (potentially controlling Kubernetes resources) or to break Argo CD functionality (by preventing connections to external clusters). How the Attack Works Argo CD stores cluster access configurations as Kubernetes Secrets. To take advantage of the vulnerability, an attacker must know the server URL for the cluster secret they want to modify. The attacker must be authenticated with the Argo CD API server, and they must be authorized to update at least one (non project-scoped) cluster. Then they must craft a malicious request to the Argo CD API server. Removing Deployment Restrictions A cluster Secret's clusterResources field determines whether Argo CD users may deploy cluster-scoped resources to that cluster. The namespaces…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-3jfq-742w-xg8j

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-23947

Advisory: Users with any cluster secret update access may update out-of-bounds cluster secrets
IDs: CVE-2023-23947, GHSA-3jfq-742w-xg8j
Record: https://patchnext.com/advisories/cve-2023-23947 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/argoproj/argo-cd 2.6.2, 2.5.11, 2.4.23, 2.3.17. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/argoproj/argo-cd: affected >= 2.3.0, < 2.3.17; >= 2.4.0, < 2.4.23; >= 2.5.0, < 2.5.11; >= 2.6.0, < 2.6.2; fixed in 2.4.23, 2.3.17, 2.5.11, 2.6.2

## Suggested inspection (read-only)
- Go github.com/argoproj/argo-cd: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/argoproj/argo-cd.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-3jfq-742w-xg8j (GitHub-reviewed advisory GHSA-3jfq-742w-xg8j lists affected ranges: Go github.com/argoproj/argo-cd >=2.3.0 =2.4.0 =2.5.0 =2.6.0 <2.6.2)

Commands are suggestions: review each one before running it.

Loading voting…