CRLF Injection in Nodejs ‘undici’ via host
CVE-2023-23936GHSA-5r9g-qh6m-jxff
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 19.6.1, 18.14.1, 16.19.1, 14.21.3; undici 5.19.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
runtime node
- Affected
- >= 14.0.0, < 14.21.3>= 16.0.0, < 16.19.1>= 18.0.0, < 18.14.1>= 19.0.0, < 19.6.1
- Fixed in
- 19.6.1, 18.14.1, 16.19.1, 14.21.3
npm undici
- Affected
- >= 2.0.0, < 5.19.1
- Fixed in
- 5.19.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5r9g-qh6m-jxff lists affected ranges: npm undici >=2.0.0 <5.19.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5r9g-qh6m-jxff lists affected ranges: npm undici >=2.0.0 <5.19.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- raw.githubusercontent.com runtime security intelligence
Node.js security working group core entry 105 lists CVE-2023-23936 affecting node >=14.0.0 =16.0.0 =18.0.0 =19.0.0 <19.6.1
VerifiedObserved Authoritative source for Node.js core CVEs: structured Node.js security-wg core vulnerability record maintained by the Node.js project.
- nodejs.org runtime security intelligence
The nodejs.org release index dates the first patched release for CVE-2023-23936 to 2023-02-16.
VerifiedObserved Official nodejs.org release index (dist/index.json).
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2023-23936: 1.13% estimated exploitation activity in the next 30 days; percentile 66.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact undici library does not protect host HTTP header from CRLF injection vulnerabilities. Patches This issue was patched in Undici v5.19.1. Workarounds Sanitize the headers.host string before passing to undici. References Reported at https://hackerone.com/reports/1820955. Credits Thank you to Zhipeng Zhang (@timon8) for reporting this vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from vendor_advisory record nodejs-security-wg:core:105
- Revision 2 · amended ·
Amended from ghsa record GHSA-5r9g-qh6m-jxff
- Revision 1 · created ·
Published from osv record GHSA-5r9g-qh6m-jxff
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-23936 Advisory: CRLF Injection in Nodejs ‘undici’ via host IDs: CVE-2023-23936, GHSA-5r9g-qh6m-jxff Record: https://patchnext.com/advisories/cve-2023-23936 (revision 3, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: node 19.6.1, 18.14.1, 16.19.1, 14.21.3; undici 5.19.1. A vendor fix does not mean a deployment is fixed. ## Affected components - runtime node: affected >= 14.0.0, < 14.21.3; >= 16.0.0, < 16.19.1; >= 18.0.0, < 18.14.1; >= 19.0.0, < 19.6.1; fixed in 19.6.1, 18.14.1, 16.19.1, 14.21.3 - npm undici: affected >= 2.0.0, < 5.19.1; fixed in 5.19.1 ## Suggested inspection (read-only) - runtime node: check the installed version with your package manager. - `npm ls undici --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on node, undici. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5r9g-qh6m-jxff (OSV record GHSA-5r9g-qh6m-jxff lists affected ranges: npm undici >=2.0.0 <5.19.1 (fixed)) - Verified: https://github.com/advisories/GHSA-5r9g-qh6m-jxff (GitHub-reviewed advisory GHSA-5r9g-qh6m-jxff lists affected ranges: npm undici >=2.0.0 <5.19.1) - Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/105.json (Node.js security working group core entry 105 lists CVE-2023-23936 affecting node >=14.0.0 =16.0.0 =18.0.0 =19.0.0 <19.6.1) - Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2023-23936 to 2023-02-16.) Commands are suggestions: review each one before running it.
Loading voting…